50410 (Создание базы данных сотрудников), страница 3

2016-07-30СтудИзба

Описание файла

Документ из архива "Создание базы данных сотрудников", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "50410"

Текст 3 страницы из документа "50410"

Min Минимальное значение

Avg Среднее значение поля

Sum Сумма значений поля по всем записям

На рисунке 16 представлен запрос с группировкой, с помощью которого можно определить значение среднего оклада, суммарную величину окладов по должностям согласно штатному расписанию, среднеквадратическое отклонение от среднего значения оклада.

Рис.16. Запрос с использованием групповых операций

7. Даты и их использование в базах данных

Операции с данными, осуществляемые пользователями, регистрируется во времени. Ввод, корректировка, удаление и другие операции регистрируются во времени. Даты используются в различных вычислениях.

Операторы работы с датами:

Date() - вывод текущей даты (число, месяц и год);

Year(Date()) - вывод текущего года;

Month(Date()) -вывод текущего месяца;

Day(Date()) - вывод текущего дня.

Определение стажа

Стаж вычисляется путем определения количества лет между датой найма и текущей датой (Рис.17).

Рис. 17. Определение стажа

Начисление надбавки за стаж:

Рис.18. Определение стажа

8. Проектирование и разработка форм

Пользователь имеет возможность создать форму самостоятельно или воспользоваться мастером. Мастер форм ускоряет процесс создания формы, так как автоматически выполняет всю основную работу. При использовании мастера Microsoft Access выдает приглашение на ввод данных, на основе которых создается форма. В созданных формах мастер можно использовать для быстрого создания элементов управления в форме. Для настройки формы следует переключиться в режим конструктора.

Недостатком форм, создаваемых мастером, является то, что они однообразны и не содержат пояснительных надписей. Чтобы приукрасить форму и расположить поля более удобным образом, следует воспользоваться конструктором форм, который позволяет передвигать и масштабировать элементы формы, связывать их с источником данных и настраивать любые другие параметры формы.

Любой элемент формы имеет контекстное меню, в котором есть команда Свойства. Выбор такой команды открывает окно свойств, подобное окну свойств формы. Вкладка Макет содержит параметры форматирования объекта. Вкладка Данные — описание источника данных, различные ограничения и условия, накладываемые на данные поля. Вкладка События (Event) позволяет писать функции отклика на различные события (например, перемещение мыши на объект). Параметры, не вошедшие впервые три группы, размещаются на вкладке Другие (Other). Вкладка Все (АН) обеспечивает одновременный доступ ко всем параметрам.

Следовательно, создание формы может осуществляться двумя способами:

  • Создание формы с помощью мастера;

  • Создание формы в режиме конструктора.

Также формы могут быть созданы на основе

  • Одной таблицы;

  • Нескольких таблиц;

  • Запросов для ввода данных в связные таблицы.

Рассмотрим создание однотабличных форм на основе таблицы Т-Кадры (Рис.19, Рис.20):

Рис.19. Однотабличная форма

Рис.20. Однотабличная форма с использованием панели элементов

С помощью кнопок панели элементов в форму можно добавлять различные объекты. Элементы управления форм и отчетов сходны между собой, поэтому такая же панель элементов имеется и в конструкторе отчетов, а все операции одинаково применимы как к формам, так и к отчетам.

Элементы управления форм:

  • Надпись (Label) - Надписи создаются автоматически вместе с элементами типа текстовое поле, поле со списком и т. п. Они разъясняют смысл поля ввода. Дополнительные надписи могут использоваться для заголовков и пояснений.

  • Поле (Text Box) - Используется для ввода и отображения информации полей таблиц и запросов, а также для вывода результатов вычислений.

  • Группа переключателей (Option Group) - Группа переключателей ссылается на некоторое поле таблицы. Каждый переключатель группы соответствует определенному целочисленному значению этого поля.

  • Выключатель (Toggle Button) - Позволяет вводить информацию типа да/нет. Величине «да» или «истина» соответствует утопленное положение выключателя.

  • Переключатель (Option Button) - Элемент группы переключателей, в которой может быть отмечен только один из них (его кружок выглядит зачерненным).

  • Флажок (Check Box) - Предназначен для представления полей типа да/нет. Отмеченный квадратик соответствует величине «да», а пустой — «нет».

  • Поле со списком (Combo Box) - Разрешает как непосредственный ввод значения в поле, так и его выбор в раскрывающемся списке предопределенных значений.

  • Список (List Box) - Позволяет выбирать данные из набора пунктов и не разрешает непосредственный ввод значений.

  • Кнопка (Command Button) - Щелчок на такой кнопке выполняет команду, с помощью которой можно перейти в другую форму, переместиться по записям и выполнить многие другие операции.

  • Рисунок - Рисунок любого графического формата с рамкой

  • Линия (Line) - Добавляет прямую линию

  • Прямоугольник (Rectangle) - Рисует прозрачный или непрозрачный прямоугольник с цветной границей любой толщины

  • Другие элементы (More Controls) - Открывает меню с элементами управления, не вошедшими в панель элементов.

Рассмотрим форму созданную на основе многотабличного запроса. В ней отражаются фамилии сотрудников, чей оклад составляет более 4000 руб. Также с помощью данной формы возможно ввести данные в связанные таблицы Т-Кадры и Т-Должность (Рис.21).

Рис. 21. Форма на основе многотабличного запроса

Создадим форму, с помощью которой можно было бы редактировать данные в таблице Т-Кадры (Рис. 22).

Рис.22. Форма с ComboBox для редактирования данных таблицы Т-Кадры

9. Разработка отчетов

Пользователь имеет возможность разработать отчет самостоятельно или создать отчет с помощью мастера. Мастер по разработке отчетов Microsoft Access выполняет всю рутинную работу и позволяет быстро разработать отчет. После вызова мастера выводятся диалоговые окна с приглашением ввести необходимые данные, и отчет создается на основании ответов пользователя.

Мастер окажется полезным даже для опытных пользователей, так как позволяет быстро разработать макет, служащий основой создаваемого отчета. После этого можно переключиться в режим конструктора и внести изменения в стандартный макет.

Источниками данных для отчетов могут быть данные одной таблицы, данные из нескольких таблиц и запросы как однотабличные, так и многотабличные. Пи выборе полей для отчета допускается выбор нескольких таблиц или нескольких запросов. В практической деятельности наибольшее применение находят отчеты на основе многотабличных запросов.

В однотабличных отчетах могут создаваться вычисляемые поля для расчета итоговых расчетов.

Существует три режима работы с отчетами: режимы просмотра образца, предварительного просмотра и конструктора.

Режим просмотра образца отчета доступен только из режима конструктора. Этот режим используется для проверки макета отчета, и в нем отображается только часть данных, которая необходима для демонстрации заполнения каждого из элементов отчета. Поскольку в таком режиме отображается лишь часть данных, создание отчета для просмотра значительно ускоряется.

Рис. 23. Режим конструктора

Режим конструктора (Рис.23) позволяет разрабатывать отчеты, а так же модифицировать их структуру и внешний вид. В этом режиме отображается Панель элементов, с помощью которой в отчете создаются элементы управления. Некоторые элементы управления могут быть созданы с помощью мастера элементов, который осуществляет пошаговое руководство процессом их создания.

Отчет, как и форма, состоит из нескольких частей, которые называются разделами. Он включает заголовок и примечание отчета, заголовки и примечания групп, верхний и нижний колонтитулы, область данных. Все разделы, за исключением области данных, являются необязательными, поэтому их можно добавлять к отчету или удалять из него в режиме конструктора с помощью команд меню Вид.

В разделе заголовка можно размещать рисунки, текст и другие элементы управления. Все они выводятся в верхней части первой страницы отчета. Раздел примечанием добавляется к отчету вместе с разделом заголовка и выводится на последней странице отчета.

Для добавления областей заголовка и примечания отчета следует активизировать команду Вид ► Заголовок/примечание отчета.

Раздел области данных, к которому можно отнести и заголовки, и примечание групп предназначен для отображения записей источника данных отчета. Этот раздел может содержать различные элементы управления для отображения данных каждой записи источника (таблицы и запроса).

С помощью команды Вид ►Колонтитулы в отчет добавляется верхний и нижний колонтитулы. Установив напротив этой команды флажок, можно удалить из отчета области колонтитулов. При этом если области колонтитулов содержат какие-то элементы, Access выдаст предупреждение о том, что при удалении областей будет удалено и их содержимое.

Размеры разделов отчета устанавливается таким же способом, как и в форме. Нужно только учесть, что размер отчета в режиме конструктора по вертикали не определяет размер готового отчета при его предварительном просмотре или печати, который зависит от количества записей, включенных в отчет.

Отчет можно вывести на печать, как из окна базы данных, так и из окон конструктора отчета или его предварительного просмотра. При этом Access учитывает настройки, заданные в диалоговом окне Параметры страницы, которая открывается с помощью команды Файл ►Параметры страницы. Параметры, заданные в этом окне, Access сохраняет вместе с проектом отчета.

Вывод отчета на печать осуществляется посредством команды Файл ►Печать. В результате ее активизации открывается диалоговое окно печать, предназначенное для установки традиционных параметров печати. Если активен режим предварительного просмотра, можно воспользоваться кнопкой Печать панели инструментов.

Например, создадим расчетную ведомость для нашего предприятия для регистрации выдачи зарплаты и отчет, содержащий фамилии работников и их зарплату, сгруппированные по должностям с итоговыми вычислениями.

На рисунке 24 приведен пример такого отчета.

Рис. 24. Расчетная ведомость для регистрации выдачи зарплаты

Свежие статьи
Популярно сейчас
Зачем заказывать выполнение своего задания, если оно уже было выполнено много много раз? Его можно просто купить или даже скачать бесплатно на СтудИзбе. Найдите нужный учебный материал у нас!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4144
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее