49030 (Создание и обработка базы данных телефонов, произведенных в разных странах), страница 2

2016-07-30СтудИзба

Описание файла

Документ из архива "Создание и обработка базы данных телефонов, произведенных в разных странах", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "49030"

Текст 2 страницы из документа "49030"

Для того чтобы привести таблицу в исходное состояние, необходимо убрать галочку возле слова «формулы».


3.3 Поиск данных

Поиск необходимых данных в таблице выполняется с помощью команды "Данные" – "Фильтр" – "Автофильтр". При этом в нижнем правом углу ячейки с названием поля появляется значок раскрывающегося списка, из него выбирается нужный критерий отбора, причем такой критерий может быть не один, то есть задать поиск можно по нескольким полям одновременно. Чтобы снять фильтр, нужно снова выполнить команду "Данные" – "Фильтр" – "Автофильтр".

Получение данных о телефонах, указанной пользователем страны с указанием города, в котором изготовлен телефон.

  1. Выполняем действия: Данные – фильтр – автофильтр.

  2. Нажимаем на стрелочку раскрывающегося списка в столбце, где указана страна и город производителя. Выбираем Условие.

3. В появившемся окне выбираем страну и город, в которой изготовлен искомый телефон и нажимаем Ок.

4. Появляется список искомых телефонов


3.4 Использование функций для получения итоговых значений

Добавление в таблицу функции может осуществляться с помощью клавиатуры, но гораздо удобнее использовать кнопку "Вставка функции" на панели инструментов. Аргументы функции и входящие в нее формулы записываются в скобках. Для изменения относительной ссылки на абсолютную надо нажать функциональную клавишу "F4".

Для подсчета общей прибыли следует установить курсор под столбцом, сумму которого мы будем искать, затем нажать на кнопку «Вставка функции», после этого в появившемся окне выбрать «СУММ» и у нас появится окошко, с указанием ячеек, сумму которых необходимо сосчитать.

В таблице отображается общая сумма искомого столбца.

Сами функции можно просмотреть, выполнив следующие действия:

1) сервис - параметры и установить галочку напротив слова «формулы»;

2) либо просто щелкнуть по ячейке с числом = среднему значению или сумме, и в строке «функции» у нас отобразится данная формула.

Для того чтобы вычислить стоимость телефона в магазине с учетом наценки и подсчитать выручку по каждому наименованию необходимо выполнить следующие действия:

1) Выделить одну из ячеек столбца с указанием фирмы-производителя;

2) Нажать кнопку «сортировка по…» на панели инструментов;

3) Выполнить команду Данные – Итоги;

4) В появившемся окне выбрать следующие данные:

5) После нажатия по кнопке Ок, в таблице появится общий итог по каждой стране-производителю:


3.5 Создание макросов

Макрос представляет собой программу, написанную на языке Visual Basic For Application, созданную либо программистом, либо макроредактором, т.е. автоматически.

Макрос позволяет запомнить действия пользователя, в том числе и ошибочные, и свести множество его действий к одному или нескольким.

Выводим курсор за пределы таблицы. Выполняем команду «Сервис – Макрос - Начать запись». После этого на экране появляется диалоговое окно, в котором можно задать имя макросу. Щелкнуть левой кнопкой мыши по кнопке OK диалогового окна Запись макроса. На экране монитора отобразится панель инструментов Остановка записи. Это означает, что Excel готов к записи макроса.


Выполняются действия: табличный курсор устанавливается внутри таблицы, Данные – Фильтр - Автофильтр, щелкаем на кнопке раскрывающегося списка «Китай. Пекин». Щелкаем на кнопке Остановить запись.

Для проверки «правильности» записи макроса необходимо снять команду Данные – Фильтр - Автофильтр, а затем выполнить команду Сервис – Макрос – Макросы и из появившегося списка макросов выбрать требуемый макрос и щелкнуть на кнопке Выполнить.

После того, как макрос создан, мы в программе Visial Basic после слова «Criterial» записываем следующее: «InputBox («введите страну»)».


И при нажатии на значок «plаy» у нас появляется окно:

После ввода страны-производителя и города, у нас отображаются все модели телефонов, изготовленные в указанной стране и в указанном городе.


При последующем нажатии по кнопке «Таблица» наша таблица возвращается в первозданное состояние.


3.6 Назначение макросов объектами

Назначить макрос можно следующим способом:

«Вид-Панель инструментов - Формы.» Находим значок с надписью «Кнопка» и создаем кнопку на нашей странице.

При необходимости кнопки можно переименовать.

3.7 Построение диаграмм

Диаграмма — это графически представленная зависимость одной величины от другой. С помощью диаграмм взаимосвязь между данными становится более наглядной. Диаграммы облегчают сравнение различных данных. Большинство диаграмм упорядочивают данные по горизонтальной (ось категорий) и вертикальной осям (ось значений). Отдельные элементы данных называются точками. Несколько точек образуют последовательность данных.Для построения диаграммы в Excel надо сначала выделить диапазон ячеек, по данным которых будет строиться диаграмма (если поля находятся не рядом, то выделение производится при нажатой клавише "Ctrl", а потом нажать на панели инструментов кнопку "Мастер диаграмм". Появляется диалоговое окно, предлагающее пользователю выбрать один из возможных типов построения диаграмм.



4. Система управления базами данных Access


4.1 Общие положения

Microsoft Access-это система управления базами данных (СУБД), предназначенная для создания и обслуживания баз данных, обеспечения доступа к данным и их обработки. Данные несут в себе информацию о событиях, происходящих в материальном мире.

База данных (БД) представляет собой организованную структуру, используемую для хранения данных, т.е. любых сведений о явлениях, процессах, действиях и т.п. Данные несут в себе информация о событиях, происходящих в материальном мире, и по сути являются зарегистрированными сигналами, возникшими в результате этих событий. Сегодня большинство СУБД размещают в своих структурах не только данные, но и методы, поэтому можно утверждать, что Microsoft Access-это СУБД, предлагающая широкий диапазон средств для хранения информации и эффективного управления этой информацией.

Базы данных несут содержат различные объекты, основными из которых являются таблицы. Структура простейшей БД соответствует структуре ее двухмерной таблицы, содержащей столбцы и строки. Их аналогами в структуре простейшей БД являются поля и записи.

4.2 Разработка структуры базы данных

Перед созданием новой реляционной базы данных с помощью Access, необходимо разработать структуру БД. В первую очередь составить списки полей. В соответствие с типом данных определить тип для каждого поля.

  • название телефона (текстовый);

  • заводская цена (числовой);

  • наценка магазина (числовой);

  • количество проданных телефонов (числовой);

  • выручка от продаж по каждой модели (числовой);

  • сведения о фирме-изготовителе (страна, город) (текстовый).

Структура таблицы определяется не только совокупностью столбцов (полей), типом и размером каждого столбца, но так же ключевым полем.

Закончив этап проектирования, приступить к созданию БД с помощью СУБД Access.

После запуска Microsoft Access одновременно с основным окном Access выводится первое диалоговое окно, позволяющее создать новую БД.

Базу данных мы разбиваем на две таблицы, в каждой из которых свои поля. Первая таблица содержит такие поля, как название телефона, заводская цена, наценка магазина и количество проданных телефонов. Вторая таблица содержит следующие поля: название телефона, выручка от продаж по каждой модели и сведения о фирме-изготовителе.

Для создания новой БД, поставить переключатель в позицию Новая база данных и выполнить щелчок на кнопке ОК, после чего откроется окно Файл новой базы данных.

В окне Файл новой базы данных задать имя файла и указать папку, куда он будет помещен, а затем выполнить щелчок на кнопке Создать. В результате откроется основное окно базы данных.

На левой панели этого окна отображены элементы управления для вызова любого из семи объектов БД: таблиц, запросов, форм, отчетов, страниц, макросов и модулей. По умолчанию активен элемент Таблицы, поэтому на правой панели представлены элементы управления для создания новой таблицы.

Распределение полей по таблицам:

В режиме «Таблица» записываем названия полей и определяем тип данных для одной и для другой таблицы.

Определяем Ключевые поля. По этим полям будут связываться данные таблицы.

На данном рисунке показана связь между БД по ключевым полям (название телефона).

4.3 Создание таблиц в режиме Конструктора

Создание таблицы, как и других объектов БД, начинается с активизации окна базы данных. В этом окне выбираешь элемент управления Таблицы, после чего на правой панели окна будет представлен список таблиц, уже входящих в состав БД. Если в базе нет таблиц, то на правую панель окна выводится только три элемента управления для создания новой таблицы: Создание таблицы в режиме конструктора, Создание таблицы с помощью мастера и Создание таблицы путем ввода данных.

Таблицы создаются в два этапа: на первом этапе определить её структуру, т. е. Состав полей, их имена, тип для каждого поля, его размер и другие свойства полей. На втором этапе заполнить таблицу данными, т. е. сформировать записи.

Для создания Таблицы1, необходимо в окне базы данных выполнить щелчок на значке Создание таблицы в режиме конструктора или щелкнуть на кнопке Создать, расположенной на верхней панели окна. В открывшемся окне Новая таблица, выбрать режим создания таблицы – Конструктор, т. к. в этом режиме можно самому устанавливать параметры всех элементов структуры таблицы.

В колонку под названием «Имя поля» вводим название данных полей, а во вторую колонку-тип данных.

Создаем вторую таблицу с несколько другими данными:

Свежие статьи
Популярно сейчас
Как Вы думаете, сколько людей до Вас делали точно такое же задание? 99% студентов выполняют точно такие же задания, как и их предшественники год назад. Найдите нужный учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4123
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее