48406 (Проектування друкованих плат пристроїв комп’ютерних систем), страница 7

2016-07-30СтудИзба

Описание файла

Документ из архива "Проектування друкованих плат пристроїв комп’ютерних систем", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "48406"

Текст 7 страницы из документа "48406"

Остаточно шлях має вигляд:

Шар 2:

(17,13),( 17, 12),( 17, 11),( 17, 10),( 17, 9),( 17, 8),( 17, 7),( 17, 6),

Перехід на шар 1:

( 17, 5),( 17, 4),( 17, 3),( 18, 3),( 19, 3),( 20, 3),( 21, 3),( 22, 3),( 23, 3),( 23, 4), ( 23, 5)

  1. РОЗПОДІЛ СПОЛУЧЕНЬ ПО ШАРАХ

Розподіл сполучень по шарам полягає в виділенні на кожному кроку сполучення з максимальним числом пересічень і вилучення його на другий шар. Сполучення переносяться з першого шару на другий до тих пір, доки не будуть усунені всі пересічення.

При виконанні розшарування необхідно отримати граф пересічень, вершини якого відповідають окремим провідникам, а ребра - їхнім пересіченням. Побудуємо граф пересічень схеми сполучень, наведеної на рис. 5.1.

Граф пересічень (рис. 5.2) можна уявити в вигляді матриці пересічень П=|| n || kk (рис. 5.3), де


Якщо провідник i перетинається з провідником j;

В противному випадку.

Рисунок. 5.1 - Комутаційна схема сполучень вузла Т1

Рисунок. 5.2 - Граф пересічень

V1

V6

V7

V8

V9

V10

V11

V13

V14

V15

V16

V17

V18

V19

V20

V21

V22

V23

V24

V1

V6

V7

V8

V9

V10

V11

1

1

V13

1

1

V14

V15

1

1

V16

V17

V18

1

1

V19

V20

1

V21

1

V22

1

1

1

V23

1

1

V24

1

Рисунок. 5.3 - Матриця пересічень

По матриці П будуємо вектор-стовпчик Е1, з нього вибираємо максимальний елемент; якщо їх декілька, то береться будь-який. Отже, беремо елемент V22 і на його місце записуємо нуль, що відповідає переносу провідника V22 на другий шар. По матриці П визначаються ребра, і в векторі-стовпчикові Е1 значення елементів, відповідних цим провідникам, зменшуються на 1, т.т. в матриці П викреслюється стовпчик, відповідний провіднику 16. Одержуємо стовпчик Е2 після першого кроку алгоритму. З стовпчика Е2 вибираємо елемент V18 і процедура повторюється, доки не дістанемося стовпчика Е5, всі елементи якого дорівнюють нулю.

V11

2

V11

1

V11

1

V11

1

V11

0

V13

2

V13

1

V13

1

V13

1

V13

0

V15

2

V15

1

V15

1

V15

0

V15

0

V18

2

V18

2

V18

0

V18

0

V18

0

E1=

V20

1

E2=

V20

1

E3=

V20

0

E4=

V20

0

E5=

V20

0

V21

1

V21

1

V21

0

V21

0

V21

0

V22

3

V22

0

V22

0

V22

0

V22

0

V23

2

V23

2

V23

2

V23

0

V23

0

V24

1

V24

1

V24

1

V24

0

V24

0

Рисунок. 5.4 - Вектори - стовпчики Е для 2-го шару

Після перенесення провідників V11, V18, V22, V23 на другий шар отримаємо двошаровий розподіл сполучень схеми.

Далі проводиться розподіл по другому шару аналогічно

Рисунок. 5.5 Граф пересічень шара 2

V11

V18

V22

V23

V11

1

V18

V22

1

V23

Рисунок. 5.6 - Матриця пересічень шара 2

Не будуючи вектори Е, можна зразу перенести V11 в 3-ій шар.

  1. РОЗРОБКА БІБЛІОТЕКИ ЕЛЕМЕНТІВ В САПР PCAD

    1. Створення символу компоненту в PCAD Schematic

Спочатку по команді Options-> Configure вибирають систему одиниць і по команді Options->Grid встановлюють необхідний крок сітки, в даному прикладі метрична система, крок сітки 5 мм.

Потім по команді Place->Line і Place->Arc малюється контур символу лініями шириною 0,25 мм.

Текстові написи наносять по команді Place->Text, висновки - по команді Place->Pin. У меню цієї команди в графі Display потрібно включити опції Pin Name і Pin Des (видимість на схемі імен і номерів висновків), в графі Length вказати довжину висновків (Short -2,5 мм, Normal - 7,6 мм, Long - 12,7 мм, User - призначається користувачем). Графіку висновків вибирають в графі Display Characteristic.

В результаті малюється заготівка символу (рис 6.1). Далі по команді Place->Attributes розміщують атрибути RefDes і Type. Всі виведення символу одержують однакове позиційне позначення за умовчанням. Виводи нумерують по команді Utils->Renumber. У графі Турі вибирають режим нумерації виведень Default Pin Des і на рядках Starting Number і Increment Value задаються початкове значення і приріст позиційних позначень виводів. Для нумерації виводів їх по черзі вибирають курсором, починаючи з першого. Як точка прив'язки по команді Place->Point звичайно відзначають верхній лівий вивід символу.

При створенні символу багатосекційного компоненту нумеруються тільки виведення першої секції, а виведення решти секцій нумеруються пізніше в таблиці виведень Pins View.

На закінчення всі об'єкти, що відносяться до символу компоненту, вибираються у вікні, і виконується команда його занесення в бібліотеку Library->Symbol Save As, при цьому елемент повинен бути виділений весь. У меню цієї команди вибирають ім'я однієї з відкритих бібліотек, куди потрібно занести створений символ, і вводять його ім'я.

    1. Створення корпусу компонентів в PCAD PCB

Спочатку по команді Options-> Configure вибирають систему одиниць і по команді Options->Grid встановлюють необхідний крок сітки, рівний відстані між висновками, в даному прикладі вибрана метрична система з кроком сітки 2,5 мм.

Потім в два ряди розміщуються 14 (16, 18 або 24) висновків з кроком 2,5 мм між висновками і відстанню між рядами 7,5 мм. Як стиль стека контактних майданчиків за допомогою команди Options->Pad Style вибирають стиль за умовчанням DEFAULT або будь-який інший. Спочатку по команді Place->Pad розміщують перше виведення компоненту. Решту висновків можна розмістити двома способами. По-перше, все їх можна розмістити уручну, продовжуючи виконання команди Place->Pad. Проте зручніше скоректувати перший висновок, вибравши його, виконавши команду Edit->Copy Matrix. Встановлюють число рядів Number of Columns - 2, відстань між рядами Column Spacing - 7,5 мм, число рядків Number of Rows - 7, і відстань між виведеннями Row Spacing - 2,5 мм. Потім крок сітки зменшують до 0,5 мм, і на шарі Top Silk малюється контур компоненту за допомогою команд Place->Line і Place->Arc лініями шириною 0,2 мм.

Далі на шар Top Silk по команді Place->Attributes/У діалоговому меню команди указують тип нумерації Pad Num, початковий номер 1 (Starting Number). Для привласнення номерів висновки по черзі позначають курсором згідно цокольовки. Як точка прив'язки по команді Place->Point/RefPoint відзначають верхнє ліве (або нижній лівий) виведення компоненту (при необхідності також відзначають Glue Dot, Pick and Place і Test Point).

Components розміщують атрибути RefDes і Type (останній повернений на 90 градусів).

При розміщенні висновків всі вони за умовчанням одержали порядковий номер 0. Автоматична нумерація висновків виконується по команді Utils->Renumber, заздалегідь включивши режим вибору.

Свежие статьи
Популярно сейчас
Почему делать на заказ в разы дороже, чем купить готовую учебную работу на СтудИзбе? Наши учебные работы продаются каждый год, тогда как большинство заказов выполняются с нуля. Найдите подходящий учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4121
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее