49942 (Создание виоролика во FLASH), страница 3

2016-07-30СтудИзба

Описание файла

Документ из архива "Создание виоролика во FLASH", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "49942"

Текст 3 страницы из документа "49942"

При просмотре фильма с помощью проигрывателя можно увидеть далеко не все. Например, если в фильм вставлен символ типа клип, то демонстрируется только его начальный кадр. Кроме того, здесь нельзя проверить, как работают сценарии.

Чтобы выполнить полноценное тестирование фильма, необходимо нажать клавиши Ctrl + Enter или выполнить команду Регулировка/Тестировать фильм (Control/Test movie).

Если необходимо протестировать только текущую сцену, нужно выполнить команду Регулировка/Тестировать сцену (Ctrl + Alt + Enter). При этом создается публикация только текущей сцены. Она записывается в одну папку с авторским фильмом, и ей дается имя, составленное из имен фильма и сцены.

1.11 Библиотека

Библиотека, которая изображена на рисунке 3, является местом размещения символов и импортированных элементов фильма. Библиотека представляет собой список содержимого, где перед каждым элементом размещена пиктограмма, указывающая на его тип. Элементы можно группировать в папки, каждую из которых можно разворачивать отдельно, что позволит минимизировать прокрутку экрана при просмотре содержимого библиотеки. Как и в случае слоев, количество элементов библиотеки быстро увеличивается по мере разработки проекта, и если их не систематизировать, наступит полная неразбериха.

Рисунок 3 - Панель Library (Библиотека)

1.12 Импорт графики

Помимо создания и анимации векторной графики непосредственно в Macromedia Flash MX можно импортировать в данный документ изображения других форматов и использовать их в данном ролике.

Использование объектов растровой графики во Flash имеет свои особенности, поскольку Flash не является растровым редактором и возможности изменения импортированной растровой графики сильно ограниченны. Для редактирования растровой графики лучше использовать отдельные редакторы (например, Adobe Photoshop или Macromedia Fire Works).

Импорт графики осуществляется с помощью команды меню Файл/Выведение/Выведение на студию. Также можно импортировать графику через буфер обмена, скопировав нужное изображение во внешнем редакторе и вставив его во Macromedia Flash MX. Однако результаты при этом бывают некорректны.

Из растровых форматов Macromedia Flash MX работает с GIF, PNG, JPEG и BMP. Важно помнить, что хотя возможно редактировать и изменять размеры растровых изображений во Flash, swf – файл всегда будет содержать информацию об оригинальном растровом изображении. Чтобы уменьшить размеры конечного файла, пользователю следует заранее привести импортируемое растровое изображение к тому размеру, в котором он желает его экспортировать.

Macromedia Flash MX позволяет преобразовать растровые изображения в объекты векторной графики. Для этого необходимо выполнить команду меню Преобразовать/Растр/Трассировка растрового изображения, предварительно выделив изображение на рабочем столе. Откроется одноименное диалоговое окно. В окне Трассировка растрового изображения доступны следующие настройки:

  • Угловой порог. Этот параметр определяет число острых углов и

сглаживаемых контуров;

  • Точность линий. Этот параметр определяет, насколько точными и

гладкими будут контуры векторизуемого изображения;

  • Минимальная область. Это параметр определяет число соседних пикселей,

учитываемых при назначении цвета конкретной области векторизуемого

изображения. Вводится число пикселей от 1 до 1000;

  • Порог цвета. Если разница в значении составляющих кодировки цвета RGB

для двух пикселей меньше цветового порога, то цвета этих пикселей считаются одинаковыми. Пользователь может вводить в соответствующее поле значения от 1 до 500. Чем выше значение, тем меньше число цветов, используемых для отображения векторной фигуры.


1.13Панель Actions

В версии MX объекты интегрированы более тесно. Теперь кнопки представляют собой истинные объекты, свойствами которых можно управлять посредством ActionScript, а видеоклипы могут получать события кнопок. Панель Actions изображена на рисунке 4.

Будучи программой, базирующейся на событиях, Flash исполняет код в ответ на какие-либо события. Во Flash 5 обработчики событий ActionScript, сигнализирующие о выполнении кода, оставались за пределами экземпляров символов, к которым осуществлялся доступ, и их нельзя было непосредственно изменить или отключить при воспроизведении фильма. В версии MX обработчики событий являются свойствами символов. Их можно даже поместить внутрь символов, так что пользователь в любое время сможет изменить обработчики событий.

Рисунок 4 - Панель Actions

ActionScript — это язык программирования, посредством которого во Flash осуществляется отправка команд и запросов о временных зависимостях, видеоклипах, кнопках и других объектах. Очень часто с помощью ActionScript можно легко достичь целей, которые в противном случае представляли бы собой труднодостижимую или, вообще, невозможную задачу. Без ActionScript можно реализовать только малую часть возможностей Flash. Например, ActionScript необходим для реализации любого рода интерактивности, например, отклика после щелчка пользователем кнопкой мыши или нажатия клавиши на клавиатуре. Кроме того, ActionScript является единственным способом реализации перехода к определенному кадру временной шкалы либо начала или остановки воспроизведения видеоклипа. Однако эти простые примеры не раскрывают богатство, гибкость и бесконечность возможностей, которые ActionScript открывает перед разработчиками, использующими среду Flash. Как правило, при использовании ActionScript удается получить SWF-файлы меньших размеров и с лучшим качеством, чем при создании промежуточных отображений. Еще одним преимуществом является то, что различные задачи удается выполнять с большей точностью, например перемещать видеоклип в точно заданное место рабочей области. Возможности языка ActionScript безграничны, а использовать его очень легко. Знакомство с ActionScript лучше всего начать с панели Actions (Действия).


1.14Доступ к панели Actions

Чтобы открыть или развернуть панель Actions, необходимо выполнить одно из следующих действий:

• из меню Window (Окно) выбрать пункт Actions (Действия);

• нажать клавишу .

После этого на экране появится или будет развернута панель Actions. Если эта панель была открыта, но скрыта другим окном, она переместится на передний план. При заданной по умолчанию компоновке панель Actions связана с панелью инспектора свойств. (Если вы хотите восстановить компоновку, заданную по умолчанию, выполните команду Window - Panel Sets - Default Layout (Окно - Наборы панелей - Размещение по умолчанию)).

Панель Actions является встроенным во Flash редактором ActionScript. При соответствующем использовании суффиксов экземпляров объектов (например, суффикс _тс для видеоклипов) в ней будет открываться вспомогательное окно с советами по применению кода.

Воспользовавшись кнопкой Pin current script (Прикрепить текущий сценарий), можно "закрепить" текущий сценарий, т.е. сохранить его на панели Actions.

1.15Использование панели Actions

Весь код на языке ActionScript вводится на панели Actions. Щелкните в кадре, на кнопке или видеоклипе, к которому требуется присоединить код ActionScript, а затем перейдите к панели Actions и в ее правой части введите код соответствующего действия.

  1. Создание видео – ролика «Химический элемент хлор» с помощью

программы Macromedia Flash

Для запуска программы выполнить команду Пуск – Программы – Macromedia- Macromedia Flash 8

2.1 Создание сцены «Представление работы»

Для создания данной сцены требуется выполнить следующие действия:

  1. выполнить команду Файл – Создать документ Flash;

  2. на временной линейке выделить первый кадр первого слоя, предварительно переименовав слой;

  3. щелкнуть левой кнопкой мыши на рабочей области в низу экрана пояаиться панель свойств Properties;

  4. на данной панели будет располеженно пиктограмма Background щелкнуть по ней левой кнопкой мыши и выбрать цвет фона;

  5. вставить слой командой контекстного меню, переименовав его в «текст». В первом кадре выбрать инструмент Text Tool, расположить его на рабочей области и написать «Химический элемент »

  1. сделать последний кадр данного слоя ключевым, нажав клавишу F6;

  1. выделить любой кадр слоя, вызвать контекстное меню и выбрать команду Создать промежуточное отбражение (Create Motion Tween);

  2. вставить новый слой. В первом кадре выбрать инструмент Text Tool, расположить его на рабочей области и написать «Хлор »

  3. сделать последний кадр данного слоя ключевым, нажав клавишу F6, в панели свойсв Properties, на этой панели распологается открывающийся список Tween, в данном списке выбрать Shape;

  4. на панели Tools выбрать элемент Color и выбрать цвет;

  5. выделить любой кадр слоя, вызвать контекстное меню и выбрать команду Создать промежуточное отбражение (Create Motion Tween);

  1. вставиь новый слой и перейти на него;

  2. выполнить команду File – Import – Import to Stage, в открывшимся диалоговом окне выбрать анимированный рисунок и нажать кнопку вставить;

  3. вставить новый слой. выбрать инструмент Text Tool, расположить его на рабочей области и написать «Вперед ». Открыть панель свойств Actions (меню ControlFnable Simple Frame Actions), в открывшимся окне написать скрипт:

on (release) {

gotoAndPlay("Scene 2", 1);

}

    1. Сцена «Свойства хлора»

Для создания данной сцены требуется выполнить следующие действия:

  1. работа с фоном аналогично пункта 2.1;

  2. Создание кнопки «Далее» аналогично пункта 2.1;

  3. вставить слой «Таблица Менделеева », выполнить команду меню File – Import – Import Stage, в открывшимся окне импорта выбрать папку с отсконированными изображениями. В ней выделить файл и нажать кнопку открыть;

  4. вставить слой «хлор », выделить последний кадр нажать клавишу F6, на последнем кадре с помощью инструмента Gradient Transform Tool, который распологается на панели инструментов Tools, трансформировать объект (т.е. размер и положение). Выполнить команду контектсного меню Создать промежуточное отбражение (Create Motion Tween).

2.3 Создание сцены «Меню»

Для создания данной сцены требуется выполнить следующие действия:

  1. работа с фоном анологично пункта 2.1;

  2. создание кнопок анологично созданию кнопки «Вперед ».

2.4 Создание сцены « Получение хлора в лабороторных условиях»

Для создания данной сцены требуется выполнить следующие действия:

  1. работа с фоном анологично пункта 2.1;

  2. создание кнопки «Далее » аналогично пункта 2.1;

  3. вставить слой «Колбы », выделить последний кадр и нажать клавишу F6;

  4. нарисовать в колбе дым с помощью панели инструментов Tools, выделить последний кадр, нажать клавишу F6, на последнем кадре изменить положение, выполнить команду контекстного меню Создать промежуточное отбражение (Create Motion Tween);

  5. вставить слой «трубка », нарисовать трубку которая соеденяет две колбы, выделить последний слой, нажать клавишу F6 и сделать заливку трубки зеленным цветом на панели свойств Properties;

  6. на данной панели будет располеженно пиктограмма Background щелкнуть по ней левой кнопкой мыши и выбрать цвет заливки;

  7. вставить слой «дым в колбе », выделить последний нажать клавишу F6, на последнем кадре поменять положение дыма;

  8. вставить новый слой. В первом кадре нарисоватьобъект, который будет имитировать (метилоаранж) расположить его на рабочей области;

  9. сделать последний кадр данного слоя ключевым, нажав клавишу F6, в панели свойсв Properties, на этой панели распологается открывающийся список Tween, в данном списке выбрать Shape;

  10. на панели Tools выбрать элемент Color и выбрать цвет;

  11. выделить любой кадр слоя, вызвать контекстное меню и выбрать команду Создать промежуточное отбражение (Create Motion Tween);

2.5 Создание сцены «Получение хлора промышленным способом»

При создании данной сцены требуется выполнить следующие действия:

  1. работа с фоном анологично пункта 2.1;

  2. создание кнопки «Далее » аналогично пункта 2.1;

  3. вставить слой «завод », выполнить команду меню File – Import – Import Stage, в открывшимся окне импорта выбрать папку с отсконированными изображениями. В ней выделить файл и нажать кнопку открыть. На последнем кадре нажать клавишу F6 и выбрать команду Создать промежуточное отбражение (Create Motion Tween);

  4. создать новый слой «дым 2», на первом кадре нарисовать дым, нажать клавишу F6, на последнем кадре выбрать инструмент Gradient Transform Toolи и изменить размеры дыма (тем самым создается эффект дымления), выбрать команду Создать промежуточное отбражение (Create Motion Tween), повторить эти действия 3 раза;

2.6 Создание сцены « Получение хлора промышленным путем (опыт)»

При создании данной сцены требуется выполнить следующие действия:

  1. работа с фоном анологично пункта 2.1;

  2. создание кнопки «Назад » аналогично пункта 2.1;

  3. вставить слой «текст», на первом кадре выбрать инструмент Text Tool расположить его на рабочей области, ввести текст, выделить последний кадр нажать клавишу F6, и выбрать команду Создать промежуточное отбражение (Create Motion Tween);

  4. нарисовать объект как показано в приложении А. Выделить последний кадр нажать клавишу F6, и выбрать команду Создать промежуточное отбражение (Create Motion Tween);

  5. нарисовать ионы Na и ионы Cl (каждый ионн отдельно и на отдельных слоях) выделить последний кадр нажать клавишу F6, переместить в конечное положение и выбрать команду Создать промежуточное отбражение (Create Motion Tween).

2.7 Создание сцены «Обесцвечивание хлором красящих веществ»

При создании данной сцены требуется выполнить следующие действия:

  1. работа с фоном анологично пункта 2.1;

  2. создание кнопки «Назад » аналогично пункта 2.1;

  3. работа с текстом анологичнопункту 2.6;

  4. вставить слой «колбы » импортировать данный рисунок в Macromedia Flash;

  5. вставить слой «бумага», на первом кадре сделать ее красной, сделать последний кадр данного слоя ключевым, нажав клавишу F6, в панели свойсв Properties, на этой панели распологается открывающийся список Tween, в данном списке выбрать Shape;

  6. на панели Tools выбрать элемент Color и выбрать цвет белый. Тогда происходит плавное обесцвечивание бумаги;

  7. выделить любой кадр слоя, вызвать контекстное меню и выбрать команду Создать промежуточное отбражение (Create Motion Tween).

2.8 Создание сцены «Реакция металлов с хлором»

При создании данной сцены требуется выполнить следующие действия:

  1. работа с фоном анологично пункта 2.1;

  2. создание кнопки «Назад » аналогично пункта 2.1;

  3. сздание анимации с изменение цвета аналогично пункту 2.4

  4. втавить слой «дождь », в первом кадре нарисовать «огненные брызги». В последнем кадре нажать клавишу F6 и Создать промежуточное отображени(Create Motion Tween).

2.9 Создание сцены «Конец»

При создании данной сцены требуется выполнить следующие действия:

  1. работа с фоном анологично пункта 2.1;

  2. создание кнопки «Смотреть еще раз анологично» пункта 2.1;

  3. вставить слой «конец », выбрать инструмент Text Tool разместить его в низу рабочей области (за кадром), написать текст, выделить последний кадр нажать на клавишу F6, и Создать промежуточное отображение(Create Motion Tween). Создается эффект титров.

2.10 Просмотр видео-ролика

Когда будут анимированы все объекты, можно просмотреть мультик с помощью горячих клавиш Ctrl + Enter или с помощью команды меню File – Publish Preview. Также программа Flash позволяет просмотреть одну сцену это можно сделать спомощью команды Control – Play или нажатием клавиши Enter.

Свежие статьи
Популярно сейчас
Зачем заказывать выполнение своего задания, если оно уже было выполнено много много раз? Его можно просто купить или даже скачать бесплатно на СтудИзбе. Найдите нужный учебный материал у нас!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4125
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее