49197 (Табличные процессоры), страница 4

2016-07-30СтудИзба

Описание файла

Документ из архива "Табличные процессоры", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "49197"

Текст 4 страницы из документа "49197"

При работе с ячейками электронной таблицы, также как и с текстовыми документами, можно использовать как жесткое, так и мягкое форматирование: либо непосредственно в ячейке задать определенный размер шрифта, либо создать стиль с необходимым размером шрифта и применить его к ячейке. Для документов, с которыми приходится работать часто, и которые при этом должны выглядеть одинаково, рекомендуется применять мягкое форматирование, т. е. воспользоваться стилем, а при работе с документами, которые необходимо только быстро напечатать, допустимо применение жесткого форматирования. Стили ячеек обеспечивают особое удобство и позволяют получать некоторые интересные эффекты.

OpenOffice Calc позволяет применять стили ячеек как в ручном режиме, так и автоматически – в зависимости от определенных условий. Если вы хотите особым образом выделить некоторые данные в таблице, например, все значения выше среднего выделить зеленым цветом, а значения ниже среднего – красным, то желаемого результата довольно просто достичь при помощи условного форматирования. Есть две возможности связать автоматическое присвоение формата ячейки с некоторыми условиями.

Первая из них – присвоение формата формулой. Функция СТИЛЬ может быть добавлена к существующей формуле в ячейке. Таким образом, вместе с функцией ТЕКУЩ вы можете задать, например, цвет ячейки в зависимости от значения. Использование формулы =...+СТИЛЬ( ЕСЛИ( ТЕКУЩ() >3; «красный»; «зеленый»)) вызывает окрашивание ячейки в красный цвет, если значение больше 3, и назначает стиль с именем «зеленый» в ином случае (разумеется, если указанные стили определены).

Другая возможность – использование условного формата. При помощи пункта Условное форматирование из меню Формат в диалоге допускается задание до трех условий, которые должны быть выполнены, чтобы ячейка или группа выделенных ячеек получила определенный формат. При изменении данных стили форматирования будут изменяться автоматически.

Формулы

При задании формул наряду с основными арифметическими операциями, OpenOffice Calc предоставляет множество специальных функций, которые можно ввести в интерактивном режиме при помощи Автопилота функций. OpenOffice Calc поддерживает, в частности, многие статистические методы: от регрессионных расчетов до доверительных интервалов. Особенно интересна возможность изменять отдельные параметры в вычислениях, зависящих от многих факторов, и прослеживать, как это влияет на результат. Это так называемые расчеты «что было бы, если». Например, при расчете кредита путем простого изменения периода, процентной ставки или сумм выплаты можно сразу же увидеть, как изменяются остальные факторы.

Как и все другие средства работы с электронными таблицами, OpenOffice Calc позволяет использовать относительные и абсолютные ссылки. Перед каждым значением, которое должно использоваться как абсолютное, ставится знак доллара $. Для превращения текущей ссылки, в которой находится курсор в строке ввода, из относительной в абсолютную и наоборот, следует использовать комбинацию клавиш Shift+F4.

Практически все функции (за исключением математических и некоторых статистических) в программе OpenOffice Calc локализованы, т. е. используют русскоязычные имена. К таковым относятся и все функции из раздела Дата&Время (однако функция ПАСХАЛЬНОЕВОСКРЕСЕНЬЕ() определяет дату католической, а не православной Пасхи).

Для ввода функций в ячейку можно воспользоваться мастером функций. Выберите ячейку, в которую надо ввести функцию, и нажмите кнопку , которая находится на панели инструментов, или выберите команду Функция... из меню Вставка. Перед вами появится окно Автопилот функций, в котором надо выделить функцию и нажать кнопку Далее>>  или OK, после чего появится окно ввода аргументов выбранной функции. Функцию можно вводить не только с помощью мастера функций, но и вручную, если вы помните, как она называется и сколько у нее параметров.

Для задания суммы чисел, находящихся в столбце или строке следует использовать кнопку . В ячейке появится формула вида =СУММ(...). Программа пытается догадаться, каков интервал суммирования. Если вас не устраивает предложенный диапазон, то выделите левой кнопкой мыши требуемую область ячеек так, чтобы вокруг нее появилась красная рамка. То же самое можно сделать и вручную, указав диапазон ячеек в строке формул. Отметим, что пустые ячейки при суммировании трактуются как содержащие нулевые значения.

Познакомимся поподробнее с функцией ДАТА, обеспечивающей ввод дат в электронную таблицу. OpenOffice Calc хранит такие данные в виде чисел, но отображает в ячейке в формате даты, выравнивая их (аналогично числам) по правому краю. Конечно, можно отформатировать ячейку, содержащую дату, и в числовом формате. Синтаксис функции – ДАТА(Год; Месяц; День). Год – целое число от 1600 до 3000, при вводе от 0 до 29 добавляется 2000, а при вводе числа от 30 до 99 – 1900. Месяц – число от 1 до 12, задающее номер месяца. День – число от 1 до 31, которое устанавливает день месяца. Когда значения месяца и дня больше допустимых, они пересчитываются на следующую позицию (год, месяц) с переполнением. Формула =ДАТА(00;12;31) дает 31.12.2000, а при вводе =ДАТА(00;13;31) получится дата 31.01.2001.

В программе OpenOffice Calc можно просто ввести даты в формате «месяц.число.год» (без указания кавычек, иначе ввод будет интерпретирован как текст), например, «5.17.2» для 17 мая 2002 года. В этом случае любой ввод со значениями, выходящими за границы допустимых, трактуется не как дата, а как текст. Функция ТДАТА() возвращает дату и время в соответствии с системным временем компьютера, которые обновляются при каждом пересчете документа.

Для того чтобы задать имя области (ячейки), необходимо эту область сначала выделить и с помощью пункта Имена – Задать меню Вставка (или при помощи комбинации клавиш Ctrl+F3) вызвать диалоговое окно Присвоить имя. Имя должно начинаться с буквы, отличаться от стандартных имен ячеек и не может содержать пробелов. После ввода имени следует нажать кнопку Добавить. В этом же диалоге можно задать имена других областей, введя сначала имя, а затем выделив ячейки листа, которые должны получить это имя. В нем можно присвоить имена даже часто используемым формулам или элементам формул.

Мощным инструментом при работе с электронными таблицами является подбор параметра. С помощью этого инструмента можно узнать значение, которое при подстановке в формулу дает желаемый результат. Для того чтобы воспользоваться подбором параметра нужно иметь формулу с несколькими постоянными значениями и одним переменным.

Диаграммы

Все рассмотренные нами программы подготовки электронных таблиц в той или иной степени могут отображать результаты расчетов в виде диаграмм. Однако ни одна из них не может на данный момент сравниться с программой OpenOffice Calc, предлагающей богатый выбор различных типов диаграмм, из которых можно выбрать наиболее подходящие для демонстрации структуры ваших данных.

Для представления данных в виде диаграммы их следует предварительно выделить (вместе с заголовками, если таковые имеются), после чего из меню Вставка выбрать пункт Диаграмма. В открывшимся окне Автоформат диаграммы нужно выполнить ряд действий, позволяющий выбрать тип диаграммы, указать расположение рядов данных, задать заголовок диаграммы, наименование осей и т. д. Если требуется вставить диаграмму в документ, состоящий из нескольких таблиц, то можно установить, в какую таблицу должна быть вставлена диаграмма. После заполнения нужных полей нажмите на клавишу Готово и диаграмма будет размещена на листе.

Заметим, что при составлении диаграмм допускается многократное выделение, т. е. выделенные данные не обязаны располагаться в таблице в виде непрерывной области. Многократное выделение осуществляется при нажатой клавише Ctrl. Если вы используете многократное выделение, то убедитесь, что этот набор разрозненных ячеек целесообразно использовать для составления диаграммы.

OpenOffice Calc позволяет изменять отдельные элементы диаграммы. Выделение диаграммы или ее части осуществляется щелчком мыши, при этом появляются восемь зеленых квадратиков, расположенных по периметру.

Курсор, попадая в выделенную таким образом область, приобретает вид крестика. Нажатие на левую кнопку мыши позволяет перемещать выделенный объект. Для удаления выделенного объекта выберите из контекстного меню пункт Вырезать.

Щелчок правой кнопкой мыши приводит к появлению меню форматирования диаграммы, пункты которого позволят откорректировать вид практически любой части диаграммы: установить границы диапазонов на осях диаграммы и масштаб, изменить прозрачность области диаграммы, задать какой–либо фон, управлять отображением сетки и многое другое.

Если вы поместили диаграмму на задний план электронной таблицы, то выделить ее просто щелчком мыши уже не удастся.

Откройте панель Функции рисования и выберите инструмент Выделение. Теперь щелчком выделите диаграмму.

При создании линейчатых диаграмм (графиков) допускается использование различных символов, которые могут быть выбраны из файлов с рисунками или из так называемой Галереи. В ней содержится большое количество рисунков для оформления границ ячеек, фоновых изображений, маркеров и «трехмерных» объектов.

Тип диаграммы можно изменить в любой момент. В диалоге, который появится благодаря выделению диаграммы и вызову команды Формат – Тип диаграммы, представлены различные типы диаграмм.

Просмотрите в этом диалоге все типы диаграмм: двумерные (2–М) и трехмерные (3–М). В 3–М–диаграммах можно настроить направление освещения, окружающий свет и цветовой фильтр. Такие диаграммы можно вращать и наклонять при помощи мыши.

Ниже приведены четыре диаграммы, соответствующие одному и тому же набору данных, полученному в результате последнего корректного многократного выделением из рассмотренного выше примера.

Одна из них – цилиндрическая с глубиной, являющаяся разновидностью 3–М гистограммы. Для лучшего обзора она была немного повернута. Другая является обычной круговой 3–М диаграммой. Оставшиеся две относятся к виду 2–М диаграмм: линия с символами, полученными из Галереи, и гистограмма, использующая различные заливки и фон.


Выводы и предложения

Электронные таблицы в настоящее время стали неотъемлемой частью программного обеспечения персональных компьютеров. Это объясняется большим набором функций для работы с данными, простотой освоения и работы, благодаря наличию разнообразных инструментальных средств – табличных процессоров. Большой выбор табличных процессоров позволяет пользователю выбрать наиболее подходящий к данной задаче.

Электронные таблицы позволяет автоматизировать процесс обработки информации, осуществлять сложные вычисления, анализировать их и представлять в наглядном виде (графики, диаграммы). В настоящее время, когда пользователь все больше обращает внимание на оперативность, наглядность предоставляемой информации, а для инженерно – технических работников все важнее становится обработка и хранение больших объемов данных, играют большую роль такие функции табличного процессора, как составление списков, сводных таблиц, возможность использования формул, копирование данных, форматирование и оформление, анализ и предоставление данных с помощью диаграмм и сводных таблиц, извлечение информации из внешних баз данных, обеспечение безопасности.

Этим же объясняется широкое применение их в различных областях деятельности человека. Они являются неотъемлемой частью информационных систем, которые облегчают доступ пользователя к информации по практически любой области науки, техники, культуры, здравоохранения, обучения, а в будущем – к знаниям, накопленным человечеством за время его существования. Кроме того, табличные процессоры, как составная часть автоматизированных информационных систем применяются на производстве: в них вводится информация о ходе выполнения производственных заказов, о наличии инструментов, сырья и т.д. В деловой сфере, где постоянно обновляются сведения о товарах и фирмах, биржевая и банковская информация без таблиц и средств работы с ними так же не обойтись. Постоянное совершенствование имеющихся пакетов электронных таблиц, появление новых делают работу с данными все более и более простой, доступной для пользователя любой квалификации.

В последнее время стало возможным в табличных процессорах создание гипертекстовых ссылок в таблице с целью перехода в другие файлы, находящиеся на компьютере пользователя, в локальной сети или в сети Internet. Данные и диаграммы можно сохранить как отдельную Web – страницу или добавлять к существующей странице.


Список использованной литературы

  1. Биллиг В.А., Дехтярь М.И. VBA и Office ХР. Офисное программирование. –М.: Русская редакция, 2004. –693 с.

  2. Гарнаев А. Использование MS Excel и VBA в экономике и финансах. –СПб.: БХВ–Петербург, 2002. –420 с.

  3. Ефимова О.В., Морозов В.В., Угринович Н.Д. Курс компьютерной технологии с основами информатики. –М.: АБФ, ACT, 1999. –482 с.

  4. Каратыгин С. и др. Базы данных: Простейшие средства обработки информации. Электронные таблицы. Системы управления базами данных. Т.1 /Каратыгин С., Тихонов А., Долголаптев В. –М.: ABF, 1995. –533 с.

  5. Ковальски С. Excel 2000 без проблем. – М.: Бином, 2000. –210 с.

  6. Информатика: учебник. Курносов А.П., Кулев С.А., Улезько А.В., Камалян А.К., Чернигин А.С., Ломакин С.В.: под ред. А.П. Курносова Воронеж, ВГАУ, 1997. –238 с.

  7. Информатика: Учебник. /Под ред. Н.В. Макаровой – М.: Финансы и статистика, 2002. –768 с.

  8. Пакеты прикладных программ: Учеб. пособие для сред, проф. образования / Э. В. Фуфаев, Л. И. Фуфаева. —М.: Издательский центр «Академия», 2004. –352 с.

Свежие статьи
Популярно сейчас
Почему делать на заказ в разы дороже, чем купить готовую учебную работу на СтудИзбе? Наши учебные работы продаются каждый год, тогда как большинство заказов выполняются с нуля. Найдите подходящий учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4123
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее