49122 (Сравнительный анализ текстовых редакторов)

2016-07-30СтудИзба

Описание файла

Документ из архива "Сравнительный анализ текстовых редакторов", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "49122"

Текст из документа "49122"

Курсовая работа

"Сравнительный анализ текстовых редакторов"

Оглавление

Введение

1. Microsoft Word

1.1 Окно программы

1.2 Работа с текстом

1.3 Редактирование текста

1.4 Форматирование текста

1.5 Печать документов

1.6 Вставка графических объектов

1.7 Вставка таблиц

2. Лексикон

2.1 Окно программы

2.2 Меню ЛЕКСИКОНа

2.3 Работа с текстом

2.4 Форматирование текста

2.5 Печать документов

3. StarWriter

3.1 Функции StarWriter

3.2 Окно программы

3.3 Проверка орфографии и сохранение документов

4. Другие текстовые редакторы

4.1 Bred

4.2 Crypt Edit

4.3 Hierogliph

4.4 KeyNote

4.5 Squall Pro

4.6 TextViewer

4.7 WinVi

4.8 Патриот

4.9 Aditor Pro

5. Практическая часть работы

Заключение

Список использованных источников

Введение

Значительную часть работы компьютера составляет выполнение функции «пишущей машинки». Но времена, когда было достаточно просто набрать текст и распечатать его на принтере, давно прошли – теперь считается вполне естественным умение редактора раскрашивать текст и фон, использовать разные шрифты, вставлять картинки, проверять правописание.

Существование различных текстовых редакторов приводит пользователя к вопросу, какой текстовый редактор лучше использовать для работы с текстом. Существует несколько аспектов этого вопроса, например, какой текстовый редактор работает быстрее, какой надёжнее, какой функциональнее и так далее. Поэтому следует разобраться в них и понять, за что пользователи предпочитают одни текстовые редакторы и оставляют в стороне другие, а также исследовать новые направления в этой области.

Сейчас в распоряжении пользователя существует много различной специальной литературы, а также электронных ресурсов, которые дают ответ на множество вопросов. Но, как правило, многие из них описывают либо определенный тип, либо определенный текстовый редактор. И чтобы найти подходящий, необходимо изучить их все. Задачи, поставленные нами в данной работе – это сравнение текстовых редакторов по различным критериям, а так же их сопоставление и выявление особенностей.

Для раскрытия поставленного вопроса в первую очередь необходимо определить само понятие текстового редактора, представить его виды. После чего провести исследования среди различных текстовых редакторов, как популярных, так и нет. Установить их особенности, достоинства и недостатки. В конце, из полученной информации составить сравнительную характеристику представленных текстовых редакторов и сделать вывод.

1. Microsoft Word

Word – мощный текстовый редактор, позволяющий быстро создать документ любой сложности из разрозненных заметок и довести до совершенства информационный бюллетень или брошюру. Редактор Word фирмы Microsoft является сегодня самой популярной в мире программой. Word начинен «быстрыми» командами и самыми современными средствами, такими как встроенная программа проверки правописания и словарь синонимов, которые помогают вам грамотно составлять документы, и готовыми шаблонами, позволяющими вам сводить воедино заметки, письма, счета и брошюры без больших усилий.

1.1 Окно программы

Многооконная организация Microsoft Word позволяет одновременно работать с несколькими документами, каждый из которых расположен в своем окне. При введении и редактировании текста пользователь работает с активным документом в активном окне. Для перехода к окну другого документа необходимо щелкнуть на его имени на панели задач или в меню Окно, которое содержит список открытых документов.

Существуют два понятия – курсор ввода и указатель мыши. Курсор ввода представляет собой мигающую вертикальную полоску |. Он указывает место, в которое будет вводиться текст. Для его перемещения используются клавиши управления курсором или мышь. Для перемещения курсора с помощью мыши следует установить указатель мыши в нужную позицию и щелкнуть клавишей мыши.

Под заголовком окна находится строка меню, через которую можно вызвать любую команду Microsoft Word. Для открытия меню необходимо щелкнуть мышью на его имени. После этого появятся те команды этого меню, которые используются наиболее часто.

Под строкой меню расположены панели инструментов, которые состоят из кнопок с рисунками. Каждой кнопке соответствует команда, а рисунок на этой кнопке передает значение команды. Большинство кнопок дублирует наиболее часто употребляемые команды, доступные в меню. Для вызова команды, связанной с кнопкой, необходимо щелкнуть мышью на этой кнопке. Если навести указатель мыши на кнопку, рядом появится рамка с названием команды.

Обычно под строкой меню находятся две панели инструментов – Стандартная и Форматирование. Чтобы вывести или убрать панель с экрана, следует выбрать в меню «Вид» пункт «Панели инструментов», а затем щелкнуть на имя нужной панели.

Режимы отображения документа:

  • Обычный – наиболее удобный для выполнения большинства операций;

  • Web-документ – отображает документ в виде Web-страницы;

  • Разметка страниц – отображает документ в точном соответствии с тем, как он будет выведен на печать; в этом режиме удобно работать с колонтитулами, фреймами и многоколонной версткой документа; только в этом режиме отображается вертикальная координатная линейка;

  • Структура – предназначен для работы со структурой документа, позволяет показывать и скрывать текст и заголовки различной глубины вложенности, создавать и работать с поддокументами.

Переход между режимами осуществляется с помощью соответствующих команд меню Вид или кнопок, расположенных слева от горизонтальной полосы прокрутки.

Для завершения работы с Microsoft Word необходимо закрыть окно программы (комбинация клавиш Alt + F4).

1.2 Работа с текстом

Курсор указывает место, в которое будет вводиться текст. Достигнув края страницы, курсор автоматически переходит в начало следующей строки. Для перехода в начало следующего абзаца следует нажать Enter.

Существует два режима ввода текста – вставки и замены. В режиме вставки при вводе новых символов, текст, содержащийся в документе, перемещается вправо от места ввода. В режиме замены старый текст заменяется новым. Переключение между режимами осуществляется двойным щелчком на индикаторе ЗАМ в строке состояния.

Прежде чем выполнить какую-нибудь операцию над фрагментом текста, его необходимо выделить одним из следующих способов:

  • установить указатель мыши в левое поле (он превратится в стрелку, направленную вправо), при нажатии клавиши мыши выделится одна строка, при двойном нажатии – абзац, при тройном – весь документ;

  • установить указатель мыши в левое поле напротив первой строки фрагмента, нажать клавишу мыши и, не отпуская ее, растянуть выделение на весь фрагмент;

  • установить указатель мыши в начале фрагмента, нажать клавишу мыши и, не отпуская ее, растянуть выделение на весь фрагмент;

  • для выделения одного слова достаточно дважды щелкнуть на нем;

  • для выделения одного абзаца можно сделать в нем тройной щелчок;

  • для выделения одного предложения следует нажать клавишу Ctrl и щелкнуть мышью в предложении;

  • для выделения всего текста следует нажать клавишу Ctrl и щелкнуть мышью в левом поле;

  • чтобы выделить фрагмент текста с помощью клавиатуры, необходимо установить курсор в начало фрагмента и, нажав клавишу Shift, клавишами управления курсором растянуть выделение на весь фрагмент.

1.3 Редактирование текста

Символ справа от курсора удаляется клавишей Delete, символ слева от курсора – клавишей Backspace. Для удаления фрагмента текста следует выделить его и нажать клавишу Delete. Если выделить фрагмент текста и набрать на клавиатуре новый текст, он вставится вместо выделенного фрагмента.

Чтобы разделить абзац на два, необходимо установить курсор в предполагаемый конец первого абзаца и нажать клавишу Enter.

Собрать два абзаца в один можно двумя способами:

  • установить курсор за последним символом первого абзаца и нажать клавишу Delete;

  • установить курсор перед первым символом второго абзаца и нажать клавишу Backspace.

Для копирования фрагмента текста необходимо:

  • выделить фрагмент текста;

  • выбрать в меню «Правка» команду «Копировать»;

  • установить курсор в место, куда следует вставить фрагмент;

  • выбрать в меню «Правка» команду «Вставить».

В процессе этой операции копия выделенного фрагмента текста помещается в буфере промежуточного хранения Clipboard, а потом попадает в документ. Вставлять фрагмент из буфера можно сколько угодно раз, но после копирования в буфер нового фрагмента текста, предыдущий фрагмент удаляется.

В Microsoft Word 2000 существует буфер обмена на 12 ячеек, с помощью которого можно копировать фрагменты таблицы не только в пределах Word но и в другие приложения, например, в Microsoft Excel. Для выведения панели буфера обмена необходимо в меню «Вид» выбрать – «Панели инструментов», потом – «Буфер обмена».

Для поиска фрагмента текста используется команда «Найти» меню «Правка». В диалоговом окне «Найти и заменить» в поле «Найти» следует ввести фрагмент искомого текста и щелкнуть кнопку «Найти» далее.

1.4 Форматирование текста

Форматирование текста – процесс установления параметров фрагмента текста, которые определяют внешний вид текста в этом фрагменте. Перед изменением параметров фрагмент текста следует выделить. Если фрагмент текста не будет выделен, то изменяться будут текущие параметры (параметры текста, который будет вводиться с текущей позиции). Для изменения параметров символов используется команда «Шрифт» меню «Формат», которая вызывает диалоговое окно «Шрифт». Вкладыш «Шрифт» используется для установления параметров шрифта.

Для изменения интервала и положения символов используется вкладыш Интервал диалогового окна Шрифт. В поле Масштаб выбирается степень растяжения или сжатия символов.

В поле Интервал устанавливается межсимвольный интервал:

1) Обычный – обычный интервал;

2) Разреженный – расстояние между символами увеличивается до значения, указанного в поле «на»;

3) Уплотненный – расстояние между символами уменьшается до значения, указанного в поле «на».

В поле смещение устанавливается вертикальное положение символов:

1) Нет – обычное положение;

2) Вверх – символы располагаются выше базовой линии на величину, указанную в поле «на»;

3) Вниз – символы располагаются ниже базовой линии на величину, указанную в поле «на».

Для изменения регистра символов в набранном тексте необходимо выделить фрагмент текста и в меню «Формат» выбрать команду «Регистр».

Стиль форматирования – набор параметров (шрифта, абзаца и пр.), имеющий уникальное имя. Выбрать стиль выделенного фрагмента текста можно в поле «Стиль» на панели «Форматирование» или в диалоговом окне «Стиль» меню «Формат». В поле «Стили» диалогового окна «Стиль» содержится список используемых стилей. Чтобы увидеть все стили следует в поле «Список» выбрать – «Всех стилей». В полях справа будут показаны образцы абзацев и символов, отформатированные этим стилем. Для присвоения фрагменту текста выделенного стиля следует щелкнуть кнопку «Применить».

Для создания нового стиля в окне «Стиль» используется кнопка «Создать». В поле «Имя» окна «Создание стиля» вводится имя нового стиля. В списке «Стиль» выбирается вид стиля: стиль абзаца или стиль символа. В поле «Основан на стиле» выбирается существующий стиль, на основе которого будет создан новый. Если установить флажок «Добавить в шаблон», то новый стиль будет действовать не только в активном окне, но и во всех документах созданных на основе этого шаблона. Для установления параметров шрифта, абзаца и др. следует щелкнуть кнопку «Формат», затем выбрать объект форматирования (Шрифт, Абзац и др.). После нажатия кнопки ОК новый стиль будет создан. Если щелкнуть кнопку «Применить» в окне «Стиль», то новый стиль будет присвоен выделенному фрагменту текста. Кнопка «Закрыть» закрывает окно без присвоения стиля. Для изменения существующего стиля следует выделить его в окне «Стиль» и щелкнуть кнопку «Изменить». В окне «Изменение стиля» можно выбрать новые параметры. Для удаления стиля его следует выделить и щелкнуть кнопку «Удалить». Создать стиль можно также по образцу. Для этого необходимо выделить фрагмент текста, взятого как образец, ввести имя стиля в поле «Стиль» на панели «Форматирование» и нажать Enter. Созданный стиль будет действовать только в активном документе.

1.5 Печать документов

Перед распечаткой документа, можно просмотреть на экране, как он будет выглядеть на печати. Для этого необходимо перейти в режим предварительного просмотра с помощью команды «Предварительный просмотр» меню «Файл». Чтобы увеличить изображение следует навести указатель мыши (он будет иметь вид лупы с плюсом), на нужный фрагмент и нажать кнопку мыши. Указатель мыши примет вид лупы с минусом и если нажать кнопку мыши, то изображение уменьшится. Выйти из режима предварительного просмотра можно с помощью кнопки «Закрыть» или клавиши Esc.

Свежие статьи
Популярно сейчас
Почему делать на заказ в разы дороже, чем купить готовую учебную работу на СтудИзбе? Наши учебные работы продаются каждый год, тогда как большинство заказов выполняются с нуля. Найдите подходящий учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4121
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее