48924 (Сервісні послуги MS Word)

2016-07-30СтудИзба

Описание файла

Документ из архива "Сервісні послуги MS Word", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "48924"

Текст из документа "48924"

17



Зміст

ВСТУП

1.1 Автоматична перевірка орфографії і граматики при введенні

1.2 Перевірка орфографії і правопису відразу у всьому тексті

1.3 Автоматичне визначення мови

1.4 Механізм визначення мови

1.5 Настройка Microsoft Word для автоматичного визначення мови

2.1 Підрахунок слів і рядків в документі

3.1 Запис макросу

3.2 Написання макросу на мові Visual Basic

3.3 Зберігання макросів

4.1. Використовування автозаміни для виправлення зроблених

5.1 Параметри меню

5.2 Відновіть початковий набір кнопок і меню на вбудованій панелі інструментів

5.3 Встановлення початкових параметрів для вбудованої кнопки

6 ОХОРОНА ПРАЦІ ТА ГІГІЄНА КОРИСТУВАЧА ЕОМ

Текстовий редактор Word є одним з найросповсюдженіших з редакторів. Це обумовлюється в першу чергу його численними перевагами, до яких належать широкі можливості. Важко знайти таку задачу при роботі з текстом, яку б неможливо було б розв’язати засобами Word.


ВСТУП

Текстовий редактор – складна сервісна програма, яка входить в склад програмного забезпечення ПЕОМ і надає “користувачу” великі можливості по обробці текстів.

З його допомогою виводиться на екран дисплея і редагується текст, який набирається на клавіатурі, дані на екрані організуються у вигляді різного роду таблиць, вихідних і вхідних форм документів: створені тексти (таблиці) заносяться на магнітний диск (магнітну стрічку) і викликаються з пам’яті на екран, принтер і т.д.

Широко розповсюджені одно-, дво- і багато віконні текстові редактори.

В найбільш простій різновидності текстового редактора –одновіконному – вікном є весь екран дисплея, на якому послідовно, по сторінках відображаються фрагменти (сторінки) тексту, таблиці або документи. При використанні багатовіконних редакторів з’являється можливість одночасного виводу в різні місця екрану різних фрагментів тексту або документу, які цікавлять “користувача” або вимагаючи редагування (виправлення). До числа сервісних програм крім текстового редактора відносять ще екранний редактор, графічний та інші.

1 Перевірка орфографії і граматики

За умовчанням Microsoft Word перевіряє орфографію і граматику автоматично при введенні тексту, виділяючи можливі орфографічні помилки червоною хвилястою лінією, а можливі граматичні помилки  - зеленою хвилястою лінією.

Також можна перевірити орфографію і граматику відразу у всьому тексті.


1.1 Автоматична перевірка орфографії і граматики при введенні

Переконайтеся, що засіб автоматичної перевірки орфографії і граматики включений.

В меню Сервіс виберіть команду Параметри, а потім відкрийте вкладку Правопис.

Встановіть прапорці Автоматично перевіряти орфографію і Автоматично перевіряти граматику. Створіть документ.

Клацніть правою кнопкою миші слово, підкреслене хвилястою зеленою або червоною лінією, а потім виберіть запропонований варіант або відповідну команду.

Для автоматичного виправлення орфографії без підтвердження кожного виправлення можна використовувати автозаміну. Якщо при перевірці знайдено слово, що починається з рядкової букви, наприклад «київ», яке є в основному словнику, але написане в ньому з прописної букви («Київ»), це слово буде помічено або виправлено автоматично (залежно від настройок). Можна вказати, щоб при перевірці правопису Microsoft Word пропускав такі слова, додавши в основний словник варіанти, що починаються з рядкової букви.


1.2 Перевірка орфографії і правопису відразу у всьому тексті

Цей спосіб корисний в тих випадках, коли перевірка тексту відкладається до завершення правки документа. Після перевірки орфографічних і граматичних помилок кожне виправлення можна підтвердити.

За умовчанням відбувається одночасна перевірка орфографії і граматики. Якщо вимагається перевірити тільки орфографію, виберіть в меню Сервіс команду Параметри, відкрийте вкладку Правопис, зніміть прапорець також перевіряти орфографію, а потім натискуйте кнопку OK.

На панелі інструментів Стандартна натискуйте кнопку Правопис.

При знаходженні помилки правопису внесіть відповідні зміни в діалоговому вікні Правопис.

Для отримання відомостей про будь-який параметр натискуйте кнопку із знаком питання, а потім клацніть необхідний параметр.

Орфографічні і граматичні помилки можна виправляти безпосереднє в документі, не закриваючи діалогове вікно Правопис. Внесіть в документ потрібне виправлення, а потім натискуйте кнопку Відновити в діалоговому вікні Правопис.

Щоб отримати докладний опис граматичної помилки, натискуйте кнопку Пояснити в діалоговому вікні Правопис.

Якщо в результаті друкарської помилки виходить слово, існуюче в словнику (наприклад, замість слова «кіт» написано слово «кіл » або замість слова «пари» написано слово «парт»), програма перевірки орфографії не помітить це слово. Для виявлення помилок такого роду використовуйте програму перевірки граматики.



1.3 Автоматичне визначення мови

При відкритті документа або введенні тексту Microsoft Word може автоматично визначати мову тексту і використовувати відповідні йому орфографічні і граматичні словники, правила пунктуації і сортування. Це дозволяє виконувати багато задач (такі як перевірка орфографії і робота з текстом на декількох мовах) автоматично при введенні тексту.


1.4 Механізм визначення мови

З метою досягнення щонайвищої точності при аналізі поєднань букв в кожній пропозиції використовуються спеціальні мовні алгоритми і статистичні дані. Для окремих слів і коротких фраз мова не визначається. При визначенні мови круг можливих рішень поступово звужується до набору мов, заданого при настройці Microsoft Word.

Мова, що використовується за умовчанням в даному документі (визначається відповідним параметром форматування звичайного стилю  (Звичайний стиль. Стиль, що використовується за умовчанням в документах, створених на основі шаблона Normal.dot.) в активному шаблоні  (Шаблон, Файл або файли, що містять структуру і інструменти для створення таких елементів закінчених файлів як стиль і макет сторінки.

Визначення мови проводиться одночасно з роботою над текстом і не заважає користувачу. В нових документах перевірка здійснюється із самого початку у міру введення кожної пропозиції, а також при копіюванні або вставці у файл фрагментів тексту. Якщо відкривається документ, який жодного разу не перевірявся, перевірці піддається кожна пропозиція. Крім того, наново перевіряється будь-яка пропозиція, якщо в нього вносяться зміни.

При відкритті документа не перевіряється текст, який вже був одного разу перевірений. Якщо мовне форматування застосовується до цілих пропозицій за допомогою діалогового вікна Мова (меню Сервіс, підміню Мову, команда Вибрати мову), це форматування також запам'ятовується і зберігається до тих пір, поки в дану пропозицію не будуть внесені зміни.

Навіть при використовуванні автоматичного визначення мови може бути потрібно застосування мовного форматування безпосередньо до тексту. Наприклад, Microsoft Word іноді не розрізняє близькі по написанню мови, такі як датський і норвезький. В таких випадках може бути автоматично застосований неправильний язиковий формат або як мова, що використовується за умовчанням, прийнята абсолютно інша мова, наприклад англійський.


1.5 Настройка Microsoft Word для автоматичного визначення мови

Для автоматичного визначення мови необхідно заздалегідь набудувати засоби багатомовної підтримки і зробити доступними мови, які використовуватимуться при редагуванні.

Крім того, Microsoft Word може використовувати різні файли перевірки орфографії і граматики для кожної мови, що використовується при введенні тексту в документ. Якщо потрібні файли неприступні на комп'ютері, Microsoft Word намагається встановити їх автоматично.

Якщо встановити потрібні для даної мови файли не вдається, може бути потрібно придбання засобів перевірки правопису Microsoft Office XP Proofing Tools, доступних на веб-вузлі Shop.microsoft.com.

Для автоматичного визначення мови в Microsoft Word необхідно також включити режим автоматичного визначення мови. Якщо мова, яка застосовується частіше за все, не є мовою редагування за умовчанням, змініть мову за умовчанням в шаблоні Normal.dot  (Шаблон Normal.dot. Універсальний шаблон для будь-яких типів документів, для зміни стандартного форматування або вмісту документа в цей шаблон можна внести необхідні зміни). Ця зміна відобразиться тільки на нових документах.

2 Статистика в Word

При необхідності Microsoft Word дозволяє зробити підрахунок слів в документі. Крім того, можна підрахувати кількість сторінок, абзаців, рядків в документі і кількість знаків (з пропусками або без).

Використання панелі інструментів «Статистика»

Для перерахунку кількості слів при додаванні або видаленні вмісту не обов'язково кожного разу вибирати в меню Сервіс команду Статистика. Натомість відобразіть панель інструментів Статистика і для оновлення статистики натискуйте кнопку Перерахунок.

Можна враховувати як звичайні, так і кінцеві виноски. Якщо необхідно отримати статистику по частині документа, а не по всьому документу, можна врахувати тільки ті виноски, які відносяться до виділеної частини документа. Крім того, для отримання статистики можна вибрати декілька розділів документа, не обов'язково розташованих поряд один за одним.


2.1 Підрахунок слів і рядків в документі

Деякі відомості в цьому розділі можуть бути незастосовний до окремих мов.

В меню Сервіс виберіть команду Статистика.

Результати всіх підрахунків відображаються в діалоговому вікні Статистика.

Якщо у міру внесення змін в документ вимагається обновляти статистику без відкриття діалогового вікна, натискуйте кнопку Панель.

На екрані з'явиться панель інструментів Статистика.

Якщо необхідно враховувати звичайні і кінцеві виноски, встановіть прапорець Враховувати всі виноски.

При отриманні статистики по частині документа враховуються тільки ті виноски, які відносяться до виділеного фрагмента.

При установці і знятті прапорця здійснюється перерахунок.

При відображенні панелі інструментів Статистика для перегляду статистики можна натискувати кнопку Перерахунок або натискувати поєднання клавіш ALT+C.

Число рядків і слів в документі відображається також на вкладці Статистика (меню Файл, команда Властивості).



3 Макроси Word

Якщо яка-небудь задача часто виконується в Microsoft Word, її виконання можна автоматизувати за допомогою макросу. Макрос  — це набір команд і інструкцій, виконуваних як одна команда.

Макроси часто використовуються для наступної мети:

Для прискорення часто виконуваних операцій редагування або форматування

Для об'єднання декількох команд, наприклад, для вставки таблиці з вказаними розмірами і межами і певним числом рядків і стовпців

Для автоматизації обробки складних послідовних дій в задачах

Для створення макросу в Microsoft Word існує два методи: використовування засобу для запису макросів і пряме програмування в редакторі Visual Basic  (Редактор Visual Basic. Середовище розробки нових і редагування існуючих програм і процедур Visual Basic для додатків. Редактор Visual Basic включає повний набір засобів відладки, що забезпечують виявлення помилок синтаксису, помилок виконання і логічних помилок в програмах.).

Для швидкого запуску макросу можна призначити йому кнопку панелі інструментів  (Панель інструментів. Панель з кнопками і параметрами, які використовуються для виконання команд. Для відображення панелей інструментів використовується діалогове вікно Настройка (виберіть в меню Вигляд команду Панелі інструментів, а потім  — команду Настройка). Для поглядання додаткових кнопок натискуйте кнопку Інші кнопки в кінці панелі інструментів.), команду меню  (Меню. Список команд, що відображається по клацанню імені меню в рядку меню або на іншій панелі інструментів.) або поєднання клавіш  (Клавіші швидкого виклику. Функціональні клавіші або поєднання клавіш, такі як F5 або CTRL+A, які служать для виконання команд меню. На відміну від них, клавішами доступу називають поєднання клавіш, такі як ALT+Ф, які переводять фокус в меню, на команду або на елемент управління.).

Якщо новому макросу задати ім'я вбудованої команди Microsoft Word, то старий макрос буде замінений новим. Наприклад, якщо записати новий макрос і задати для нього ім'я FileClose, цей макрос буде пов'язаний з командою Закрити. Після цього при виборі команди Закрити Microsoft Word виконуватиме дії, задані в новому макросі.


3.1 Запис макросу

Засіб запису макросів дуже корисно, особливо для початківців. В цьому випадку макрос буде записаний у вигляді серії команд Word на мові Visual Basic для додатків  (VBA. Макро-версія мови програмування Microsoft Visual Basic, що використовується для програмування додатків Microsoft Windows і що поставляється з деякими додатками (Microsoft). ). Запис макросу можна тимчасово припинити, а потім продовжити.

Для вибору команд і параметрів допускається застосування миші. Проте дії, виконані у вікні документа за допомогою миші, не записуються. Для запису таких дій, як переміщення курсора, а також виділення, копіювання і переміщення тексту, необхідно використовувати клавіатуру.

Перед записом макросу заплануйте наперед кроки і команди, які він повинен виконати.

Якщо при записі буде допущена помилка, то в макросі також запишуться всі виправлення. Непотрібні інструкції можна буде прибрати пізніше шляхом редагування макросу.

Постарайтеся передбачити всі повідомлення Microsoft Word, які можуть припинити дію макросу або направити його по помилковому шляху.

Якщо макрос викликає команду Знайти або Замінити (меню Правка), натискуйте кнопку Більше на вкладці Знайти або Замінити, а потім виберіть параметр Скрізь в списку Напрям. Якщо макрос виконує пошук тільки вперед або назад, то по досягненні кінця або початку документа Word припинить виконання макросу і запропонує продовжити пошук в частині документа, що залишилася.

Перед використовуванням макросу, записаного в іншому документі, переконайтеся, що він не залежить від вмісту цього документа.

Свежие статьи
Популярно сейчас
Как Вы думаете, сколько людей до Вас делали точно такое же задание? 99% студентов выполняют точно такие же задания, как и их предшественники год назад. Найдите нужный учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4121
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее