48861 (Розробка автоматизованого обліку та руху товарів на складах засобами СУБД Microsoft Access), страница 2

2016-07-30СтудИзба

Описание файла

Документ из архива "Розробка автоматизованого обліку та руху товарів на складах засобами СУБД Microsoft Access", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "48861"

Текст 2 страницы из документа "48861"

Microsoft Access в даний час є однією з найпопулярніших серед настільних (персональних) програмних систем управління базами даних. Серед причин такої популярності слід зазначити:

• високий ступінь універсальності і продуманості інтерфейсу, який розрахований на роботу з користувачами самої різної кваліфікації. Зокрема, реалізована система управління об'єктами бази даних, що дозволяє гнучко і оперативно переходити з режиму конструювання в режим їх безпосередньої експлуатації;

• глибоко розвинені можливості інтеграції з іншими програмними продуктами, що входять до складу Microsoft Office, а також з будь-якими програмними продуктами, що підтримують технологію OLE;

• багатий набір візуальних засобів розробки.

Не можна не відзначити, що істотною причиною такого широкого розповсюдження MS Access є і могутня рекламна підтримка, здійснювана фірмою Microsoft. В процесі розробки даного продукту на ринок представлялися його різні версії. Найбільш відомими стали Access 2.0, Access 7.0 (він вперше був включений до складу програмного комплексу MS Office 95). Пізніше з'явилися версії Access 97 (у складі MS Office 97) і Access 2000 (у складі MS Office 2000). Очевидно, що відправною крапкою в процесі роботи з будь-якою СУБД є створення файлу (або групи файлів) бази даних. На мал. 1 показано вікно, яке з'являється після створення нової бази.

Мал. 1. Головне вікно бази даних в Access

Основні розділи головного вікна відповідають типам об'єктів, які може містити база даних Access. Це Таблиці, Запити, Звіти, Макроси і Модулі. Заголовок вікна містить ім'я файлу бази даних.

Інтерфейс роботи з об'єктами бази даних уніфікований. По кожному з них передбачені стандартні режими роботи:

• Створити — призначений для створення структури об'єктів;

  • Конструктор — призначений для зміни структури об'єктів;

  • Відкрити (Перегляд. Запуск) — призначений для роботи з об'єктами бази даних.

Важливим засобом, що полегшує роботу з Access для користувачів, що починають, є майстри — спеціальні програмні надбудови, призначені для створення об'єктів бази даних в режимі послідовного діалогу. Для досвідчених і просунутих користувачів існують можливості гнучкішого управління ресурсами і можливостями об'єктів СУБД в режимі конструктора. Специфічною особливістю СУБД Access є те, що вся інформація, що відноситься до однієї бази даних, зберігається в єдиному файлі. Такий файл має розширення *.mdb. Дане рішення, як правило, зручно для непрофесійних користувачів, оскільки забезпечує простоту при перенесенні даних з одного робочого місця на інше. Внутрішня організація даних в рамках mdb-формату мінялася від версії до версії, але фірма Microsoft підтримувала їх сумісність від низу до верху, тобто бази даних з файлів у форматі ранніх версій Access можуть бути конвертовані у формат, використовуваний у версіях пізніших.

Розділ 3. Розробка автоматизованого обліку та руху товарів на складах засобами СУБД Microsoft Access

Як неважко здогадатися, процес розробки конкретного програмного застосування в середовищі Access в першу чергу визначається специфікою наочної області, що автоматизується. Проте для більшості з них можна виділити ряд типових етапів. Це:

  • розробка і опис структур таблиць даних;

  • розробка схеми даних і завдання системи взаємозв'язків між

  • таблицями:

  • розробка системи запитів до таблиць бази даних і (при необхідності) їх інтеграція в схему даних;

  • розробка екранних форм введення/висновку даних;

  • розробка системи звітів по даним;

  • розробка програмних розширень для бази даних, вирішальних специфічні завдання по обробці інформації, що міститься в ній, за допомогою інструментарію макросів і модулів;

  • розробка системи захисту даних, прав і обмежень по доступу.

Очевидно, що між перерахованими етапами існує велика кількість зворотних зв'язків, повернення до перших кроків, виходячи з обставин, що знов відкрилися, які неможливо було наперед врахувати або передбачати.

Ще раз підкреслимо, що описана послідовність етапів розробки бази даних в MS Access не є безумовним еталоном. Проте дуже часто відхилення від неї свідчать не стільки про оригінальність ходу думки розробника, скільки про погрішності, допущені ним при плануванні процесу розробки, або взагалі про відсутність у нього якого-небудь плану.

3.1 Розробка таблиць БД

Як вже наголошувалося раніше, процес розробки бази даних в СУБД MS Access починається із завдання опису структур таблиць. Розглянемо цей процес детальніше.

Отже, спершу нам необхідно створити опис таблиці. Натиснувши кнопку Створити і вибравши в діалоговому вікні режим Конструктор, ми потрапляємо у вікно, призначене для введення опису структури створюваної таблиці. Воно зображене на мал.2.

При створенні баз даних, призначених для вирішення фінансових і економічних завдань, процес опису атрибутів полів в створюваній таблиці набуває особливого значення. Як видно з мал. 2, процес опису атрибутів поля починається з привласнення йому імені (ідентифікатора). Бажано, щоб це ім'я було, з одного боку, інформативним, а з іншої — коротким, що забезпечує безперечні зручності при подальших маніпуляціях з ним. Далі необхідно визначити тип поля, що, очевидно, повинно робитися, виходячи із змісту тих даних, які в нім зберігатимуться.

Мал. 2. Створення опису структури таблиці Паперу

Вибір типу даних в Access одночасно визначає набір додаткових атрибутів відповідного поля:

  • формат поля, що визначає умови виведення даних з цього поля (за умовчанням);

  • маска введення, що визначає умови введення даних в полі;

  • підпис — містить розширений заголовок;

  • значення за умовчанням — дозволяє вказати значення, що автоматично привласнюється полю при створенні нового запису;

  • умова на значення — визначає вимоги до даним, що вводяться в поле;

  • повідомлення про помилку — визначає текст повідомлення, яке

  • виводитиметься у разі порушення заданої вище умови;

  • обов'язкове поле — указує, вимагає чи ні поле обов'язкового

  • введення значення;

  • індексоване поле — визначає індекс, що створюється по даному

  • полю. Індекс прискорює виконання запитів, в яких використовуються індексовані поля, і операції сортування і угрупування.

Ґрунтуючись на досвіді проектування різних баз, необхідно відмітити, що не слід нехтувати можливостями управління даними, які відкривають додаткові атрибути полів. Їх грамотне і продумане використання дозволяє організувати централізований і ефективний контроль за коректністю і цілісністю даних.

На завершальному етапі процесу проектування структури таблиці відбувається завдання ключів і індексів. У першому випадку досить виділити рядки, які повинні скласти ключовий вираз, і клацнути мишею по піктограмі Ключ на панелі інструментів.

Також при створенні таблиці має сенс наперед продумати можливі впорядкування, які можуть знадобитися при роботі з даними, що містяться в ній. Завдання індексів з відповідними ключовими виразами може надалі істотно прискорити процес роботи (особливо з великими масивами даних). Після створення опису структури таблиці можна перейти в режим безпосереднього введення в неї даних. Як вже мовилося, важливою перевагою інтерфейсу СУБД Access є продумана гнучка система переходу від режиму Конструктора до режиму введення даних в таблицю (Режим таблиці). Такий перехід можна здійснити, клацнувши мишею по піктограмі Вигляд, розташованою на панелі інструментів, або вибравши функцію меню Вигляд - Режим таблиці. Очевидно, що ті дії, які були детально описані для таблиці, слід виконати і для решти інформаційних масивів. В результаті ми отримаємо систему таблиць бази даних. Підкреслимо, саме систему, так як дані, які знаходяться в ній тісно зв’язані між собою.

Механізм опису логічних зв'язків між таблицями в Access реалізований у вигляді об'єкту, який називається Схемою даних. Перейти до її створення можна з панелі інструментів база даних, доступною з головного вікна.

Мал. 3 Створення схеми даних

Альтернативний варіант виклику даного режиму доступний через меню Сервіс - Схема даних.

Інтерфейс завдання зв'язків між полями в схемі заснований на «перетяганні» (переміщенні при натиснутої лівої кнопки миші) вибраного поля і «накладенні» його на те поле, з яким повинен бути встановлений зв'язок. Для скріплення відразу декількох полів їх слід переміщати при натиснутій клавіші Ctrl. Виділяють декілька типів зв'язків між таблицями в схемі. «Один до одного» (1:1) — одному значенню поля в одній таблиці відповідає тільки одне значення поля в іншій. «Один до багатьом» (1:со) — одному значенню поля в одній таблиці відповідає декілька (одне або більш) значень в іншій. Найважливішим завданням, яке дозволяє вирішувати схема, є забезпечення логічної цілісності даних в базі.

3.2 Розробка запитів до бази даних

Поява навіть дуже невеликої таблиці миттєво приводить до виникнення цілого комплексу проблем, пов'язаних з необхідністю обробки що містяться в ній даних. До простих завдань обробки можуть бути віднесені:

  • пошук запису по умові (див. функцію меню Правка > Знайти);

  • сортування записів в необхідному порядку (див. функцію меню Запису -

  • Сортування);

  • отримання вибірки записів таблиці, що задовольняє заданій умові, або. як ще говорять, завдання фільтру для таблиці (Записи -

  • Фільтр).

Перераховані функції також доступні з контекстного меню, що активізується після натиснення правої клавіші миші. Даний інтерфейс представляється особливо зручним при практичній роботі з таблицями Access. Проте цих можливостей явно недостатньо для завдань обробки даних, які виникають в реальних економічних додатках. Для їх вирішення в СУБД Access служить розвинений інструментарій запитів до бази даних. Поняття запиту в Access уживається в розширювальному плані. Його слід трактувати як деяку команду на вибір, перегляд, зміну, створення або видалення даних. Також не можна не відзначити значення запитів для вирішення завдань аналізу даних.

Найбільш поширеним і. якщо так можна виразитися, природним типом запитів є запит на вибірку. Даний тип, власне кажучи, і встановлюється за умовчанням для новостворюваного запиту.

При роботі з системою даних дуже часто виникає завдання з'єднання даних з різних зв'язаних таблиць в одну.

Для її вирішення слід перейти до розділу Запити головного вікна бази даних, натиснути на кнопку Створити і вибрати режим Конструктор. Процес створення запиту починається з вибору таблиць (у тому числі і інших запитів), на основі яких будується запит. Надалі склад цього набору може бути змінений. В процесі формування запиту можна виділити ряд принципових етапів:

  • опис структури запиту (тобто вказівка того, яка інформація повинна виводитися в колонках таблиці запиту);

  • завдання порядку, в якому дані повинні виводитися при виконанні запиту;

  • завдання умов виведення записів в запиті.

  • На мал. 4 показано вікно конструктора запиту.

Мал. 4 Вікно конструктора запиту

Слід звернути увагу на виключно важливу роль механізму запитів у вирішенні проблеми забезпечення мінімальної надмірності інформації, що зберігається в базі. Дійсно, з їх допомогою ми можемо отримувати довільну кількість віртуальних таблиць, що представляють в самих різних видах і розрізах єдину сукупність даних, що реально зберігається.

Розглянемо ще один випадок застосування запитів для вирішення завдань обробки даних. Достатньо типовою (зокрема для додатків фінансово-економічного характеру) є проблема угрупування даних за тією або іншою ознакою. Для активізації можливості їх завдання у вікні Конструктора запитів необхідно включити функцію меню Вигляд > Групові операції.

Також слід звернути увагу на такі важливі можливості конструктора запитів, як:

• завдання параметрів, що запрошуються при відкритті запиту;

• вбудовані статистичні функції, доступні при завданні групових операцій. Вони роблять запити могутнім інструментом аналізу

інформації, що зберігається.

На завершення огляду засобів побудови запитів в СУБД Access слід вказати також і на те, що в неї крім могутнього і ефективного візуального конструктора вбудований також і режим безпосереднього введення SQL-виразів, що визначає запит. Даний режим існує паралельно і доступний з меню Вигляд > Режим SQL (а також з піктограми Вигляд на панелі інструментів).

3.3 Розробка форм

Будуть розглянуті режими безпосереднього введення даних в таблицю. Очевидно, що це має вельми обмежене застосування. Це обумовлюється як тим, що довжина запису може виявитися чималою і вводити інформацію в неї в табличній формі буде технічно незручно, так і міркуваннями більш принципового характеру:

• по-перше, структура таблиці повинна будуватися на основі логіки

завдань зберігання інформації, яка, взагалі кажучи, може істотно

відрізнятися від логіки її накопичення і введення;

  • по-друге, важливим показником якості автоматизованої системи

  • є організація її системи введення/виведення у вигляді, максимально наближеному до традиційних форм представлення інформації на немашинних носіях. Такі форми, як правило, роблять програмне

  • забезпечення привабливим для кінцевого користувача, зменшують

  • період його адаптації до знов впроваджуваної системи і дозволяють швидко зосередитися на рішенні основних професійних задач;

  • по-третє, в складній і розвиненій автоматизованій інформаційній

  • системі повинне забезпечуватися розділення доступу до різних груп

  • полів і записів для різних категорій користувачів залежно від

  • виконуваних ними функцій. Також в певних ситуаціях потрібно представити одну і ту ж інформацію або в різних видах і розрізах, або в різних поєднаннях з іншою інформацією.

Для вирішення як цих, так і багатьох інших проблем організації інтерфейсу введення/виведення даних в Access служить механізм електронних форм. Виберемо вкладку Форми головного вікна бази даних і натиснемо кнопку Створити. Діалогове вікно, що з'являється, дозволяє вибрати як таблицю або запит, для роботи з даними яких складається форма, так і режим її створення. Залежно від кваліфікації користувача і, природно, складності форми, що розробляється, можна або скористатися вбудованими програмними надбудовами-майстрами, або відразу почати її створення з нуля в режимі Конструктора. Вельми плідним також виявляється комбінований підхід: спочатку використовується відповідний майстер, а потім отримана форма додатково допрацьовується в «ручному режимі».

За умовчанням формі було запропоновано привласнити таке ж ім'я, як і у таблиці, на основі якої вона була створена. При створенні підписів полів програмна надбудова використовувала їх відповідні атрибути, задані при конструюванні таблиці. Останнє не завжди буває зручним з погляду інтерфейсу користувача. Для усунення цих і подібних недоліків нам доведеться повернутися в режим зміни макету форми (кнопка Конструктор або піктограма Вигляд на панелі інструментів). Технологія процесу проектування форм в середовищі Access зводиться до додавання елементів, що управляють, і зміни їх властивостей. У зв'язку з цим при переході в режим Конструктор на екрані за умовчанням з'являються два додаткові вікна: Вікно Панель елементів, яке призначене для вибору наступного управляючого елементу, що додається до проектованої форми. У конструктор форм Access вбудовані такі елементи управління, як напис, поле, кнопка, прапорець, перемикач, список, набір вкладок і ін. Крім цього до форми можна підключати спеціальні (додаткові) елементи управління OLE, що значно розширює можливості розвитку інтерфейсу управління даними. Вікно Властивостей поточного елементу управління, призначене для зміни його атрибутів і настройок, наприклад, кольору, шрифту, розміру і т.п.

Свежие статьи
Популярно сейчас
Как Вы думаете, сколько людей до Вас делали точно такое же задание? 99% студентов выполняют точно такие же задания, как и их предшественники год назад. Найдите нужный учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4100
Авторов
на СтудИзбе
670
Средний доход
с одного платного файла
Обучение Подробнее