48600 (Разработка объектно-ориентированной модели информационной системы учебной библиотеки), страница 3

2016-07-30СтудИзба

Описание файла

Документ из архива "Разработка объектно-ориентированной модели информационной системы учебной библиотеки", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "48600"

Текст 3 страницы из документа "48600"

Для создания Кооперативной диаграммы нажала клавишу F5.

Рисунок 3 Диаграмма Сотрудничества

Вывод: Как видно из рисунка 3, здесь представлена вся та информация, которая была и на диаграмме последовательности, но кооперативная диаграмма по-другому описывает поток событий. Из нее легче понять связи между объектами, однако труднее уяснить последовательность событий.

По этой причине часто для какого-либо сценария создают диаграммы обоих типов. Хотя они служат одной и той же цели и содержат одну и ту же информацию, но представляют ее с разных точек зрения.

На кооперативной диаграмме, так же как и на диаграмме последовательности, стрелки обозначают сообщения, обмен которыми осуществляется в рамках данного варианта использования. Их временная последовательность, однако, указывается путем нумерации сообщений.

5 Создание диаграммы классов

Этапы выполнения:

Настройка:

  1. В меню модели выбрала пункт Tools > Options (Инструменты > Параметры).

  2. Перешла на вкладку диаграмм.

  3. Убедилась, что помечен контрольный переключатель Show Stereotypes (Показать стереотипы).

  4. Убедилась, что помечены контрольные переключатели Show All Attributes (Показать все атрибуты) и Show All Operations (Показать все операции).

  5. Убедилась, что не помечены переключатели Suppress Attributes (Подавить вывод атрибутов) и Suppress Operations (Подавить вывод операций).

Создание пакетов:

  1. Щелкнула правой кнопкой мыши на Логическом представлении браузера.

  2. В открывшемся меню выбрала пункт New > Package (Создать > пакет).

  3. Назвала новый пакет Entities (Сущности).

  4. Повторила этапы с первого по третий, создав пакет Boundaries (границы).

Создание Главной диаграммы Классов:

  1. Дважды щелкнула на Главной диаграмме Классов прямо под Логическим представлением браузера, чтобы открыть ее.

  2. Перетащила пакет Entities из браузера на диаграмму.

  3. Перетащила пакет Boundaries из браузера на диаграмму.

Главная диаграмма Классов представлена на рисунке 4.

Рисунок 4. Главная диаграмма Классов системы учебной библиотеки.

Создание диаграммы Классов для сценария "ввод новой книги" со всеми классами.

  1. Щелкнула правой кнопкой мыши на Логическом представлении броузера.

  2. В открывшемся меню выбрала пункт New > Class Diagram (Создать > Диаграмму Классов).

  3. Назвала новую диаграмму Классов add New book (Введение новой книги).

  4. Щелкнула в браузере на этой диаграмме дважды, чтобы открыть ее.

  5. Перетащила из браузера все классы (ins_book, number_izd).

Диаграмма Классов представлена на рисунке 5.

Рисунок 5 Диаграмма Классов add New book.

Добавление стереотипов к классам:

  1. Щелкнула правой кнопкой мыши на классе ins_book диаграммы.

  2. В открывшемся меню выбрала пункт Open Specification (Открыть спецификацию).

  3. В поле стереотипа выбрала слово Boundary. Нажала на кнопку ОК.

  4. Щелкнула правой кнопкой мыши на классе number_izd диаграммы.

  5. В открывшемся меню выбрала пункт Open Specification (Открыть спецификацию).

  6. В раскрывающемся списке в поле стереотипов указала Entity. Нажала на кнопку ОК.

Измененная диаграмма Классов представлена на рисунке 6.

Рисунок 6 Стереотипы классов для варианта использования ввод новой книги.

Объединение классов в пакеты:

  1. Перетащила в браузере класс ins_book на пакет Boundaries.

  2. Перетащила класс number_izd на пакет Entities.

Добавление диаграмм Классов к каждому пакету:

  1. Щелкнула правой кнопкой на пакете Boundaries браузера.

  2. В открывшемся меню выберите пункт New > Class Diagram (Создать > Диаграмму Классов).

  3. Ввела имя новой диаграммы - Main (Главная).

  4. Дважды щелкнула мышью на этой диаграмме, чтобы открыть ее.

  5. Перетащила на нее из браузера класс ins_book.

Повторила пункты 1-4 для пакета Entities.

Вывод: Диаграмма классов определяет типы классов системы и различного рода статические связи, которые существуют между ними. В этом разделе были нанесены классы на диаграмму. А так же сгруппированы в пакеты классы, созданные во время выполнения предыдущего раздела. Созданы несколько диаграмм Классов, на которых также показаны классы и пакеты системы.

6 Добавление деталей к описаниям операций и определение атрибутов классов. Добавление связей между классами

Этапы выполнения:

Настройка:

  1. В меню модели выбрала пункт Tools > Options.

  2. Перешла на вкладку Diagram.

  3. Убедилась, что переключатель Show Visibility помечен.

  4. Убедилась, что переключатель Show Stereotypes помечен.

  5. Убедилась, что переключатель Show Operation Signatures помечен.

  6. Убедилась, что переключатели Show All Attributes и Show All Operations помечены.

  7. Убедилась, что переключатели Suppress Attributes и Suppress Operations не помечены.

  8. Перешла на вкладку Notation.17

  9. Убедилась, что переключатель Visibility as Icons не помечен.

Добавление нового класса:

  1. Нашла в браузере диаграмму Классов варианта использования "ввод новой книги".

  2. Щелкнула на ней дважды, чтобы ее открыть.

  3. Нажала кнопку Class панели инструментов.

  4. Щелкнула мышью внутри диаграммы, чтобы поместить там новый класс.

  5. Назвала его Ekzemplar (Экземпляр).

  6. Назначила этому классу стереотип Entity.

  7. В браузере перетащила класс в пакет Entities.

Добавление атрибутов:

  1. Щелкнула правой кнопкой мыши на классе n_izd (номер издания).

  2. В открывшемся меню выбрала пункт New Attribute (Создать атрибут).

  3. Ввела новый атрибут n_izd: Integer (номер издания). Нажала клавишу Enter.

  4. Ввела следующий атрибут kol_ekz: integer (количество экземпляров).

  5. Повторила этапы 3 и 5, добавив атрибуты Avtor_naz (автор и название книги), Izdat (издательство), God_izd (год издания), Data_postup (дата поступлния), Kol_str (количество страниц), Otdel (отдел), Znak_avtora (знак автора), Cena (цена), Ot_kogo (на чьи средства приобретена книга).

  6. Щелкнула правой кнопкой мыши на классе ekzemplar (экземпляр).

  7. В открывшемся меню выбрала пункт New Attribute (Создать атрибут).

  8. Ввела новый атрибут n_inventar: Integer (инвентарный номер). Нажала клавишу Enter.

  9. Ввела следующий атрибут data_spis: date (дата списания).

  10. Повторила этапы 9 и 11, добавив атрибуты N_izd (номер издания), Prichina (причина списания), N_ab (номер абонента), Data_vydachi (дата выдачи), N_akta (номер акта списания).

Добавление операций к классу ekzemplar:

  1. Щелкнула правой кнопкой мыши на классе ekzemplar.

  2. В открывшемся меню выбрала пункт New Operation (Создать операцию).

  3. Ввела новую операцию Create. Нажала клавишу Enter.

  4. Ввела следующую операцию SetInfo. Нажала клавишу Enter.

  5. Ввела следующую операцию GetInfo. Нажала клавишу Enter.

Подробное описание операций с помощью диаграммы Классов:

  1. Щелкнула мышью на классе number_izd, выделив его таким способом.

  2. Щелкнула на этом классе еще один раз, чтобы переместить курсор внутрь.

  3. Отредактировала операцию Create(), чтобы она выглядела следующим образом: Create() : Boolean

  4. Отредактировала операцию SetInfo(), чтобы она выглядела следующим образом: SetInfo(n_izd :Integer, Avtor_naz: string, Izdat: string, God_izd: string, Data_postup: date, Kol_ekz: integer, Kol_str: string, Otdel: string, Znak_avtora: string, Cena: byte, Ot_kogo: string) : Boolean

  5. Отредактировала операцию GetInfo(), чтобы она выглядела следующим образом: GetInfo() : String.

  6. Повторила соответствующие действия с остальными операциями.

Добавление связей связи к классам, принимающим участие в варианте использования "Ввод новой книги":

Этапы выполнения:

Настройка:

  1. Нашла в браузере диаграмму Классов "Ввод новой книги"

  2. Дважды щелкнула на ней, чтобы открыть ее.

  3. Проверила, имеется ли на панели инструментов диаграммы кнопка Unidirectional Association.

Добавление ассоциаций:

  1. Нажала кнопку панели инструментов Unidirectional Association.

  2. Нарисовала ассоциацию от класса воод книги (ins_book) к классу номер издания (n_izd).

  3. Повторила этапы 1 и 2, создав еще ассоциации: от класса n_izd к классу экземпляр (ekzemplar)

  4. Щелкнула правой кнопкой мыши на однонаправленной ассоциации между классами ins_book и number_izd, со стороны класса ins_book.

    1. В открывшемся меню выбрала пункт Multiplicity > Zero or One.

    2. Щелкнула правой кнопкой мыши на другом конце однонаправленной ассоциации.

    3. В открывшемся меню выбрала пункт Multiplicity > Zero or One.

Повторила этапы 4 - 7, добавив на диаграмму значения множественности для остальных ассоциаций.

Вывод: Система состоит из большого количества классов и объектов. Ее поведение обеспечивается взаимодействием объектов. Два типа отношений, которые можно выделить на этапе анализа, - это ассоциация и агрегация.

В результате выполнения этапов были добавлены атрибуты и операции к классам диаграммы Классов "ввод новой книги". Для атрибутов и операций использованы специфические для языка особенности.

7 Создание диаграммы состояний и диаграммы компонентов

7.1 Создание диаграммы состояний

Диаграммы состояний определяют все возможные состояния, в которых может находиться конкретный объект, а также процесс смены состояний объекта в результате наступления некоторых событий.

На диаграмме имеются два специальных состояния - начальное (start) и конечное (stop). Начальное состояние выделено черной точкой, оно соответствует состоянию объекта, когда он только что был создан. Конечное состояние обозначается черной точкой в белом кружке, оно соответствует состоянию объекта непосредственно перед его уничтожением. На диаграмме состояний может быть одно и только одно начальное состояние.

Для того чтобы построить диаграмму состояний, ее вначале необходимо создать и активизировать.

Создание диаграммы состояний: нашла в браузере класс ekzemplar. Щелкнула на классе правой кнопкой мыши и в открывшемся меню указала пункт New > Statechart Diagram.

Добавление начального и конечного состояний:

  1. На панели инструментов нажала кнопку Start State (Начальное состояние). Поместила это состояние на диаграмму.

  2. На панели инструментов нажала кнопку End State (Конечное состояние). Поместила это состояние на диаграмму.

Добавление суперсостояния: на панели инструментов нажала кнопку State (Состояние). Поместила это состояние на диаграмму, назвала его Initialization (Инициализация). Поместила еще одно суперсостояние и назвала его Filled (Выполнен).

Подробное описание состояний:

  1. Дважды щелкнула на состоянии Initialization (Инициализация).

  2. Щелкнула правой кнопкой мыши на окне Actions (Действия).

  3. В открывшемся меню выберала пункт Insert (Вставить).

  4. Дважды щелкнула мышью на новом действии.

  5. Назвала его Store Come Date (Сохранить дату поступления).

  6. Убедилась, что в окне When (Когда) указан пункт On Entry (На входе).

  7. Повторила этапы 3-6, добавив следующие действия: Collect Info (Собрать информацию из накладной и из книги), в окне When указала пункт Do. Add Items (Добавить к екземпляру новые графы), в окне When указала Do.

  8. Нажала на кнопки ОК два раза, чтобы закрыть спецификацию.

  9. Дважды щелкнула на состоянии Filled (Выполнен).

  10. Повторила этапы 2 - 7, добавив действие Print kat kart (напечатать каталожную карточку), указала пункт Do.

Добавление переходов:

  1. На панели инструментов нажала кнопку Transition (Переход). Щелкнула мышью на начальном состоянии. Провела линию перехода к состоянию Initialization (Инициализация).

    1. Повторила те же действия, создав следующие переходы: от состояния Initialization (Инициализация) к состоянию Filled (Выполнен).

    2. От состояния Filled (Выполнен) к конечному состоянию.

Подробное описание переходов:

  1. Дважды щелкнула на переходе от состояния Initialization (Инициализация) к состоянию Filled (Выполнен), открыв окно его спецификации.

  2. В поле Event (Событие) ввела фразу Add Item (Добавить к заказу новую позицию).

  3. Перешла на вкладку Detail (Подробно). В поле Condition (Условие) ввела No unfilled items remaining (Не осталось незаполненных позиций).

Результат выполнения этапов по созданию диаграммы состояний представлен на рисунке 8.

Свежие статьи
Популярно сейчас
Почему делать на заказ в разы дороже, чем купить готовую учебную работу на СтудИзбе? Наши учебные работы продаются каждый год, тогда как большинство заказов выполняются с нуля. Найдите подходящий учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4144
Авторов
на СтудИзбе
666
Средний доход
с одного платного файла
Обучение Подробнее