48563 (Разработка имитационной модели системы массового обслуживания), страница 4

2016-07-30СтудИзба

Описание файла

Документ из архива "Разработка имитационной модели системы массового обслуживания", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "48563"

Текст 4 страницы из документа "48563"

procedure N8Click (Sender: TObject) - Выбор вкладки главного меню "О программе";

procedure N9Click (Sender: TObject) - Выбор вкладки главного меню "Помощь";

Ниже приведены глобальные переменные, используемые в программе.

i: integer; // минуты {общее время}

min: integer; // минуты {время моделирования}

chas: integer; // часы

vr_mod: integer; // время моделирования

klienty: array of array of integer; // массив с клиентами

proced: array of array of integer; // массив процедур

nom_pr: array of integer;

klient: integer; // кол-во клиентов

kol_proced: integer; // кол-во процедур

vremya: integer; // время появления каждого клиента

dlina: integer; // длина очереди

obsl: integer; // число обслуженных клиентов

nepol_obsl: integer; // число не полностью обслуженных клиентов

neobsl: integer; // число необслуженных клиентов

proced_kl: integer; // кол-во процедур у каждого клиента

f,j,h,k: integer;

vr_pr: integer;

dopol_och, ochered: array of array of integer; // массив очереди

och_pr: array of array of integer;

maxim, max: integer; // максимальная длина очереди

stop,pusk, dl,x: integer; // счетчики

y,dlina_och2, est,c,q, t,l,null: integer; // счетчики

сlient, minim,pr, b: integer;

s_r, s: string;

na_obsl: integer; // клиенты на обслуживании

dlina_och: integer; // длина очереди

eff_rab: real; // эффективность работы процедуры

proiz_rab: real; // Производительность работы

obch_eff: real; // эффективность работы системы

3.4 Результаты экспериментов

В данном проекте были проведены статистические исследования, чтобы проверить, как работает данная система при разных настройках. Результаты данного исследования приведены в таблице 3.1

Таблица 3.1 - Результаты статистического исследования

Экс-пери-мента

Время модели-рования, часы

Время ожидания заявки в очереди, минуты

Число аппа-ратов обслу-живания

Макси-мальная длина очереди

Число обслу-женных клиентов

Число необслу-женных

клиентов

Общая эффекти-вность

работы системы,%

Общая про-изво-дитель-ность,%

1

1

10

4

10

1

8

58,74

11,11

2

2

10

4

10

2

5

45,41

28,57

3

3

10

4

10

7

16

38,88

30,43

4

9

10

4

10

1

75

51,47

1,33

5

1

10

3

10

3

5

51,1

37,5

6

2

10

3

10

3

15

70,83

16,16

7

3

10

3

10

13

11

71,66

54,16

8

9

10

3

10

2

72

36,97

2,7

9

1

20

5

10

0

7

43,99

0

10

2

20

5

10

8

7

56,66

53,33

11

3

20

5

10

13

8

51,99

61,9

12

9

20

5

10

6

63

60,03

8,69

13

1

20

6

10

5

2

22,49

71,42

14

2

20

6

10

12

3

27,63

80

15

9

20

6

10

69

6

39,31

92

По полученным данным можно сказать, что при увеличении числа аппаратов общая эффективность работы возрастает, а производительность системы при этом падает. Из всех экспериментов лучшим результатом по эффективности работы был при времени моделирования 3 часа, с количеством аппаратов - 3 (т.е. минимальное число аппаратов). Эффективность при этом была равна 71, 66%.

А по производительности лучший результат при времени моделирования 9 часов, с количеством аппаратов 6 (т. е максимальное число аппаратов).

3.5 Руководство пользователю

Для запуска программы необходимо открыть исполняемый файл "SMO. exe". При этом появится заставка программы (Рисунок 3.1). Если вы желаете начать работу необходимо нажать кнопку "Старт", если вы желаете выйти выберите "Выход".

Рисунок 3.1 - Заставка программы

При нажатии на кнопке "Старт" появляется главное окно программы.

В начале работы активизируется вкладка "Начальные параметры". Здесь пользователь может задать свои параметры системы, такие как время моделирования, время ожидания в очереди, количество процедур, периодичность прихода клиентов, время процедуры, максимальная длина очереди, количество процедур для клиента (Рисунок 3.2). На вкладке также имеются кнопки "Пуск", "Остановить", "Выход", которые соответственно позволяют начать процесс моделирования, остановить его и завершить работу.

Рисунок 3.2 - Вкладка "Начальные параметры"

При запуске процесса моделирования на вкладке "Результаты" отображаются данные по текущему состоянию каждой процедуры, а также в виде диаграммы представляется эффективность работы каждой из них (Рисунок 3.3).

Рисунок 3.3 - Вкладка "Результаты"

При остановке работы или после окончания процесса моделирования появляется отчет о проделанной работе. Его можно увидеть, если выбрать вкладку "Отчет" в главном окне программы (Рисунок 3.4). В нем указывается вся общая информация, информация по всем процедурам (Число обслуженных клиентов, время занятости, время простоя, эффективность работы). Если есть необходимость отчет можно сохранить в текстовом файле.

Рисунок 3.4 - Вкладка "Отчет"

Разработка меню. Меню проекта располагается в верхней строке экрана. Своим присутствием оно создает значительные удобства пользователям для работы с программой. После открытия проекта пользователь может выбирать нужные команды.

В меню программы имеются вкладки: "Файл", "Моделирование", "Справка".

В вкладке меню "Файл" находятся команды: "Сохранить отчет", "Начальные параметры", "Результаты", "Показать отчет", "Выход" (Рисунок 3.5).

Рисунок 3.5 - Вкладка главного меню "Файл"

Команда "Сохранить" необходима для сохранения отчета о проделанной работе после окончания процесса моделирования.

Команда "Начальные параметры" позволяет открывать вкладку "Начальные параметры" для изменения настроек системы.

Команда "Результат" позволяет открывать вкладку "Результаты" для наблюдения текущего состояния каждой процедуры.

Команда "Показать отчет" позволяет открывать вкладку "Отчет".

В вкладке меню "Моделирование" находятся команды: "Запустить", "Остановить", "Очистить параметры" (Рисунок 3.6).

Рисунок 3.6 - Вкладка "Моделирование" главного меню

Команда "Запустить" необходима для запуска процесса моделирования.

Команда "Остановить" позволяет остановить процесс моделирования.

Команда "Очистить параметры" позволяет очистить все начальные параметры системы и удаляет результаты предыдущего моделирования.

Во вкладке меню "Справка" находятся команды: "О программе", "Помощь" (Рисунок 3.7).

Рисунок 3.7 - Вкладка "Справка" главного меню

Команда "О программе" позволяет посмотреть информацию о программе и авторе программы (Рисунок 3.8).

Рисунок 3.8 - Вызов справки о программе

Команда "Помощь" позволяет ознакомиться с общим руководством по работе данной системы (Рисунок 3.9).

Рисунок 3.9 - Вызов общей справки по системе

Панель инструментов. С помощью панели инструментов можно быстро сохранить отчет, начать процесс моделирования, остановить процесс моделирования, очистить начальные параметры, а также посмотреть общую справку по системе (Рисунок 3.10).

Рисунок 3.10 - Панель инструментов


Заключение

Разработанная в ходе выполнения курсового проекта имитационная модель системы массового обслуживания "Поликлиника" является актуальной на сегодняшний день, так как предоставляет большие возможности для анализа работы системы и принятия решений в различных ситуациях на практике.

Моделируя реальные процессы, пользователь может проследить, как изменяется эффективность работы системы. А затем, может сделать выводы о том, при каких установках система будет работать максимально производительно, сколько следует установить аппаратов, чтобы время простоя аппарата было минимально, а время занятости максимальным.

В ходе разработки данного проекта были приобретены практические навыки системного исследования реальной динамической сложной системы на основе построения ее имитационной модели.

Также были решены задачи, поставленные в начале работы. Мной были разработаны собственные алгоритмы для решения этих задач. Разработанная программа устойчиво выполняет все свои функции, но теперь стоит задача сделать ее более совершенной и более расширенной.


Список используемой литературы

  1. Лифшиц А.Л. Статистическое моделирование СМО, М., 1978.

  2. Советов Б.А., Яковлев С.А. Моделирование систем, М: Высшая школа, 1985.

  3. Пригодин Н.В. Системный подход в моделировании М., 1986.

  4. А.Я. Архангельский. Программирование в Delphi 7.

  5. Электронный учебник по курсу "Прикладная теория систем"

  6. Методическое обеспечение по курсу "Прикладная теория систем"

Свежие статьи
Популярно сейчас
Как Вы думаете, сколько людей до Вас делали точно такое же задание? 99% студентов выполняют точно такие же задания, как и их предшественники год назад. Найдите нужный учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4121
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее