48407 (Проектування засобів обчислювальної техніки в САПР PCAD 2008 (схема формувача імпульсів))

2016-07-30СтудИзба

Описание файла

Документ из архива "Проектування засобів обчислювальної техніки в САПР PCAD 2008 (схема формувача імпульсів)", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "48407"

Текст из документа "48407"

Міністерство Освіти України

Чернівецький Національний Університет

Фізичний Факультет

Кафедра ЕОМ

7.09.1501 Комп’ютерні системи та мережі

Проектування засобів обчислювальної техніки в САПР PCAD 2008

(схема формувача імпульсів)

Курсова робота

Керівник

Викладач кафедри ЕОМ

Л.М. Павліна,

Виконала

Студентка 407 групи

О.М. Кочержук

2008

Анотація

В даному курсовому проекті розглянуто проектування друкованих плат в пакеті програм САПР P-CAD 2008. В якості прикладу використано схему управління освітленням з будь-якого пульту ДУ.

ЗМІСТ

Вступ

1. Основні поняття і загальні принципи проектування в PCAD

1.1 Огляд PCAD Schemantic

1.2 Огляд PCAD PCB 15

1.3 Принцип створення власних компонентів

2. Опис побудови принципової схеми та трасування плати в середовищі PCAD-2008

3. Опис принципової схеми формувача імпульсів

Висновок

Література

Вступ

При розгляді САПР необхідно врахувати поставлену задачу і в зв’язку з її вимогами обирати систему автоматизованого проектування, яка є найбільш підходящою. В роботі описується побудова принципової схеми формувача імпульсів та трасування плати в середовищі PCAD 2008


1. Основні поняття і загальні принципи проектування в PCAD

Процес проектування в P-CAD складається з двох основних етапів – набору принципової схеми потрібного електротехнічного пристрою і розведення друкованої плати. Це здійснюється в окремих незалежних програмах пакету.

PCAD Schematic – програмна оболонка з набором можливостей для швидкого і ефективного створення принципових схем. Вона включає набір зручних потужних інструментів для розміщення, редагування і перегляду схем. Базові можливості програми:

  • Розміщення, редагування, зміна розмірів і положення компонентів, підтримка Drag-And-Drop.

  • Можливість проектування схеми на кількох листах. Встановлення атрибутів листів, компонентів і зв’язків.

  • Перевірка електричної коректності схеми.

  • Динамічне пересилання між програмами пакету.

  • Підтримка ієрархічних проектів.

  • Спільні бібліотеки з програмою розведення плат.

  • Розширені можливості друку.

P-CAD PCB – професійна програма проектування друкованих плат. Вона містить набір можливостей для швидкого і ефективного розведення плат. До основних можливостей P-CAD PCB відносять:

  • Розведення плат з кількістю слоїв до 99, окреме планування доріжок живлення і землі.

  • Атрибути плати, компонентів і доріжок повністю можуть контролюватись користувачем.

  • Автоматичне слідкування за допустимою відстанню між доріжками, відстеження помилок.

  • Повне редагування елементів компонент, включаючи слої.

  • Динамічна пересилка між програмами пакету.

  • Спільні бібліотеки з програмою набору схем.

  • Розширені можливості друку

1.1 Огляд P-CAD Schematic

До базових функцій, які потрібно знати для нормальної роботи в P-CAD Schematic відносять:

Інтерфейс користувача P-CAD Schematic побудований згідно стандартів програм Windows з доданням специфічних для P-CAD елементів управління.

Головне меню (Menu bar) дозволяє легко виконувати команди та функції P-CAD Schematic. Для активізації меню досить вибрати його мишкою або натиснути відповідну гарячу клавішу разом з клавішею ALT. Якщо при зміні розмірів вікна програми меню починає виходити за границі, здійснюється його перенесення у наступний рядок. На відміну від цього інші елементи вікна P-CAD Schematic відображені не будуть.

Панель інструментів (Toolbars)– це група кнопок, які дозволяють виконувати найбільш часто вживані команди і функції P-CAD Schematic. Відображення панелей інструментів можна увімкнути в меню View. Як тільки панель інструментів буде відображена на екрані можна використовувати мишу для перенесення її в нове місце. Подвійне натиснення лівої кнопки миші поверне панель інструментів на початкову позицію. Якщо притримати вказівник миші над будь-якою кнопкою панелі інструментів, на екран буде виведено підказку, яка пояснює призначення даної кнопки.

Командна панель інструментів – набір кнопок які виконують функції командного та інших меню. Відповідне призначення кнопок при переліку зліва направо: вибір, новий файл, відкрити файл, зберегти файл, роздрукувати файл, вирізати, копіювати, вставка, відмінити останню операцію, ручна проводка, перейменування мережі, лінійка, збільшення, записати порядок технічних змін.

Панель інструментів встановлення – реалізує команди встановлення елементів на робочий простір P-CAD Schematic. При переліку зліва направо кнопки панелі мають відповідні значення: покласти компонент, покласти провідник, покласти шину, покласти порт, покласти контакт, покласти лінію, покласти дугу, покласти багатокутник (полігон), покласти точку, покласти текст, встановити атрибут, покласти поле і покласти символ функціонального призначення.

Окрім двох попередніх панелей є можливість створити вибіркову командну панель. Вибрати компоненти, які ввійдуть в неї можна функцією Customize меню Utils.

Лінія підказки знаходиться в нижній частині робочої області P-CAD Schematic. На ній відображається інформація про комбінації клавіш і стан об'єктів в процесі редагування.

Нижче знаходиться лінія статусу. На ній розміщені наступні елементи.

  1. Координати X та Y. Ці два значення містять інформацію про позицію вказівника миші або вставленого об'єкта. Під час встановлення об'єкта перейти в ці поля можна, натиснувши клавішу J.

  2. Кнопки переключення сітки дозволяють перемикати установки відображуваної сітки з абсолютних на відносні та навпаки. При абсолютному відображенні за точку відліку для координатної сітки використовується лівий нижній кут робочого простору. При відносному відображенні точку відліку можна встановити в будь-якому місці робочого простору. Це можна здійснити в меню Options Grids. Перемикання можна здійснювати клавішею А.

  3. Поле завдання кроку координатної сітки. Крок задається в мілідюймах, дюймах або міліметрах. Одиниці виміру по замовчуванню встановлюються в меню Options Configure в полі Units.

  4. Кнопка запису тимчасового макросу. Можна активувати клавішею М. Після натискання кнопки в пам'яті буде записана послідовність дій редагування поки не буде повторно натиснено кнопку М. Запускається макрос клавішею Е. При цьому записані елементи будуть відображені в позиції миші.

  5. Поле переліку листів. Якщо в проекті використовується кілька листів з схемами, їх можна перемикати в цьому полі. Перемикання може здійснюватись клавішами L та Shift+L.

  6. Поле товщини лінії – задає товщину лінії по замовчуванню.

  7. Поле статусу. Тут будуть відображатись певні дані, серед яких номера вибраних об'єктів, відносні зміщення об'єктів в координатній сітці, ім'я вибраної мережі, результат вимірів лінійкою і наступна деталь яку буде встановлено в режимі встановлення деталей.

Робоча область – це логічна область розробки. Вся поверхня робочої області розмічена сіткою. Розмір робочої області можна змінити в меню Options Configure, тому зовсім не обов'язково форма вікна P-CAD Schematic співпадатиме з границями області.

P-CAD дозволяє оперувати з кількома відкритими вікнами проектів і відповідно кількома робочими областями рівноправно, тобто можна одночасно редагувати кілька проектів.

Команди перегляду меню View

Команди перегляду використовуються для управління зовнішнім виглядом проекту на екрані. Можна здійснити збільшення зображення для більш детального перегляду схеми. Можна здійснити зменшення зображення для отримання повного вигляду проекту. Сканування дозволяє пересувати екран з зображенням схеми. Команди переходу дозволяють перейти на потрібну деталь або положення.

View Zoom In/Out. При виборі цього елемента меню курсор миші змінить форму стрілки на лінзу. Натиснення лівої кнопки миші при наведенні на певну частину схеми призводить до збільшення або зменшення частини робочої області. Фактор збільшення можна задати в меню Options Configure. Подібні дії, але без фокусування виконує натиснення клавіш “+” і “-“.

View Zoom Window – дозволяє виділити збільшуваний фрагмент мишею. Викликається також клавішею Z. Виділений фрагмент збільшується до розмірів вікна проекту.

View Jump to a Part. Команда здійснює перехід на вказаний компонент. Компонент вибирається в списку Parts. Компонент буде відображений в центрі робочої області.

View Jump Text. Команда використовується для пошуку текстових рядків в проекті і переміщення області відображення в позицію шуканого тексту.

Jump to a Node. При використанні діалогу Edit Nets можна використати команду Jump to a Node для переміщення області відображення на потрібний вузол. Вузол вибирається в списку вузлів.

Використання листів

P-CAD Schematic дозволяє встановлювати лист по замовчуванню а також додавати, знищувати, модифікувати і перевизначати листи в проекті.

При створенні листа необхідно вказати його унікальне ім'я. P-CAD Schematic присвоює номери листів послідовно, використовуючи наступний доступний номер. Щоб створити лист, слід:

В Options Sheets діалозі ввести нове ім'я листа.

Натиснути кнопку Add.

Дії над об'єктами

Як і в усіх Windows-програмах, в P-CAD є можливість повноцінно працювати з структурами меню і панелей інструментів. Інтерфейс програми забеспечує достатню потужність, гнучкість і логічно інтуітивний інтерфейс.

Команди Options Sheet можуть використовуватись для поточного листа. Об'єкти кладуться і вибираються кожен окремо на поточний лист. Також можливе використання блочного вибору об'єктів на поточному листі.

Одним з найбільш потужних аспектів інтерфейсу P-CAD є можливість модифікувати властивості одного або кількох об'єктів шляхом їх вибору і здійснення дії за вибором користувача. Об'єкти можуть вибиратись окремо, поблочно або іншими засобами. Після того, як об'єкти вибрані, можна вибрати всі асоційовані за мережею об'єкти, знищити їх, перемістити як групу або підсвітити. Якщо об'єкти одного типу – це дозволяє запросити і відредагувати їхні властивості. Більшість асоційованих з об'єктом команд може бути відображена натисненням правої кнопки миші на вибраному об'єкті.

Встановлення об'єктів

P-CAD Schematic дає змогу створювати нові об'єкти або встановлювати вже створені, такі як компоненти, в проект.

Об'єкти які можуть бути встановленні на лист перелічені меню Place і дублюються на панелі інструментів встановлення. Призначення кнопок цієї панелі було описане вище. Коли натискається одна з цих кнопок, дія, якій вона відповідає, залишається активною, доки не буде натиснена кнопка, що виконує іншу дію. Наприклад після натиснення кнопки Place Line і натискання лівої кнопки миші на робочій області будуть встановлюватись сегменти лінії доки не буде натиснуто клавішу Esc або праву кнопку миші. Встановлення об'єкта завжди здійснюється відносно координатної сітки.

Переважна більшість об'єктів може бути обернена або відображена (дзеркально). Для обертання виділеного об'єкта слід натиснути клавішу R, яка здійснює поворот об'єкта на 90 градусів проти годинникової стрілки. Для відображення виділеного об'єкта використовується клавіша F.

При встановленні в проект ліній можна натискати клавішу О для циклічного перебору ортогональних режимів. Дозволені ортогональні режими визначаються параметрами в діалозі Options Configure. Для встановлення ліній режими обмежені лінійними сегментами (відсутні дуги).

Використання команди Snap to Grid меню View дозволяє увімкнути швидкий режим курсору. Це означає, що курсор миші може переміщуватись тільки від точки до точки координатної сітки. Крім цього таким чином пересувати курсор завжди можна клавішами зі стрілками (клавішами курсору) на клавіатурі.

Вибір об'єктів

Засоби вибору об'єктів дозволяють вибирати об'єкти розміщені на листі проекту. Вибір може бути здійснений:

  1. виконанням команди Select меню Edit;

  2. активацією кнопки вибору на командній панелі інструментів;

  3. натисканням клавіші S.

Після вибору об'єкт підсвічується окремим кольором вибраного об'єкту (по замовчуванню жовтим), який можна встановити в діалозі Options Display. При виборі об'єкта, його назва або номер висвічується на лінії статусу.

Як тільки було здійснено перемикання в режим вибору, можна вибирати довільний об'єкт натисканням на ньому лівої кнопки миші. Вибір всіх інших об'єктів при цьому буде скасований.

Якщо в проекті зустрічаються об'єкти, які перекриваються, вибір потрібного здійснюється натисканням клавіші пробілу або послідовним натисненням лівої кнопки миші на цьому ж місці.

Вибрати декілька об'єктів можна натиснувши клавішу Ctrl і вибираючи їх мишею, як було вказано вище. Кількість вибраних об'єктів відображується на лінії статусу. Після відпускання клавіші Ctrl для скасування вибору всіх об'єктів достатньо вибрати мишею порожнє місце на проекті.

Свежие статьи
Популярно сейчас
Почему делать на заказ в разы дороже, чем купить готовую учебную работу на СтудИзбе? Наши учебные работы продаются каждый год, тогда как большинство заказов выполняются с нуля. Найдите подходящий учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4125
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее