48368 (Проектирование информационной системы сети поликлиник), страница 3

2016-07-30СтудИзба

Описание файла

Документ из архива "Проектирование информационной системы сети поликлиник", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "48368"

Текст 3 страницы из документа "48368"

Результаты разработки представлены в виде диаграммы классов на рисунке 6, описание назначения классов по слоям – в таблице 1.

Таблица 1 – Назначение классов концептуальной модели

Наименование класса

Назначение класса

Слой представления

E-UI-Registrator

Граничный класс, отвечающий за отображение формы личной карты пациента, параметров и результатов поиска.

E-UI-Doctor

Граничный класс, отвечающий за отображение формы истории болезни пациента.

E-UI-LDC

Граничный класс, отвечающий за отображение формы сведений о прохождении исследовании / сдачи анализов пациентом.

ControllerTreatment

Управляющий класс, методы которого отвечают за управление приложением в целом

Слой предметной области

CallService

Граничный класс, отвечающий за взаимодействие с классами слоя предметной области.

PatientData

Класс хранения, содержащий ключевые данные о пациенте.

eDiagnose

Класс хранения, содержащий сведения о поставленном диагнозе

eResult

Класс хранения, содержащий данные результатов исследования.

eNaprav

Класс хранения, содержащий сведения о направлении пациента на исследования / сдачу анализов.

eMedcard

Класс хранения, содержащий медицинскую карточку.

eOperator

Класс хранения, содержащий сведения об операторах, работающих с ИС.

AccessList

Класс хранения, содержащий права доступа операторов ИС.

Слой источника данных

Data

Граничный класс, отвечающий за взаимодействие с БД.

Рисунок 6 – Диаграмма классов, моделирующая структуру ИС на концептуальном уровне

  1. Логическая модель информационной системы

    1. Модель поведения

Рисунок 7 – Диаграмма последовательности, моделирующая функцию создания новой записи

Рисунок 8 – Диаграмма последовательности, моделирующая функцию редактирования записи

Рисунок 9– Диаграмма последовательности, моделирующая функцию поиска записи

Рисунок 10 – Диаграмма последовательности, моделирующая функцию
аутентификации оператора

Рисунок 11– Диаграмма последовательности, моделирующая функцию удаления

Рисунок 12 – Диаграмма последовательности, моделирующая функцию создания отчета

    1. Модель структуры

На рисунке 13представлена диаграмма классов ПО ИС, на которой отражены все классы, составляющие ПО ИС постановки пациента на учет в поликлинике. Данная диаграмма представляет всю модель структуры ПО ИС и получена в результате решения задач первой итерации проектирования. При необходимости проектант, получив целевую модель структуры, может вернуться к уточнению требований, сформулированных в концепции и выполнить вторую итерацию проектирования, результатом которой может быть уточненные модели поведения и структуры, как на концептуальном, так и на логическом уровне.

Рисунок 13 – Диаграмма классов, моделирующая структуру ПО ИС на логическом уровне

  1. Реализация модели в среде CASE-средства

    1. Начало работы над проектом

Запустить программу Rational Rose Enterprise Edition. Создать новый проект: FiIe→New.

После того, как проект будет создан и работа с ним будет завершена, необходимо сохранить полученные диаграммы. Для этого в меню File выбрать пункт Save или Save As, дать имя проекту и сохранить его в файл с расширением *.mdl.

    1. Разработка диаграммы вариантов использования

Для создания главной диаграммы вариантов использования в программе Rational Rose необходимо выполнить следующие действия:

Дважды щелкнуть по пункту Main (Главная диаграмма) в разделе Use Case View (Представление прецедентов) в списке браузера, чтобы открыть диаграмму.

В списке браузера выбрать актера или требуемый прецедент и перетащить его на диаграмму с помощью мыши.

Актеры и прецеденты могут быть получены прямо на диаграмме с использованием панели инструментов.

Чтобы создать коммуникативные ассоциации в программе Rational Rose необходимо:

  1. На панели инструментов щелкнуть по кнопке Association (Ассоциативная связь) или по кнопке Unidirectional Association (Однонаправленная ассоциативная связь). Если нужная кнопка отсутствует нужно щелкнуть правой кнопкой мыши на панели инструментов, в появившемся контекстно-зависимом меню выбрать команду Customize (Настройка), чтобы добавить кнопку.

  2. Щелкнуть по актеру – инициатору связи – и перетащить возникшую линию связи на нужный прецедент.

    1. Разработка диаграммы действий

Диаграммы действий в Rational Rose создаются следующим образом:

  1. Щелкнуть правой кнопкой мыши по разделу Use Case View (Представление прецедентов) в списке браузера.

  2. В появившемся контекстно-зависимом меню выбрать команду New → Activity Diagram (Создать →Диаграмма действий). В список будет добавлена новая диаграмма, которой нужно дать имя.

  3. Для того, чтобы открыть диаграмму необходимо дважды щелкнуть по ней мышью в браузере.

Действием называется исполнение определенного поведения в потоке управления системы.

Создание действий:

  1. Щелкнуть по кнопке Activity (Действие) на панели инструментов.

  2. Щелкнуть по диаграмме действий, чтобы переместить элемент, изображающий действие, на диаграмму.

  3. Ввести имя нового действия.

Переходы используются для изображения пути потока управления от действия к действию.

Создание переходов:

  1. Щелкнуть по кнопке State Transition (Переход) на панели инструментов.

  2. Щелкнуть по начальному действию на диаграмме и переместить стрелку перехода на последующее действие.

При моделировании управляющих потоков системы часто требуется показать места их разделения на основе условного выбора. Переходы из элемента выбора содержат ограничительные условия, определяющие, какое направление перехода будет выбрано. Элементы выбора и условия позволяют задавать альтернативные пути потока управления.

Создание элементов выбора

  1. Щелкнуть по кнопке Decision (Элемент выбора) на панели инструментов.

  2. Щелкнуть по диаграмме действий, чтобы переместить на нее элемент выбора.

  3. Ввести имя нового элемента.

Секции делят диаграммы действий на несколько участков. Это нужно для того, чтобы показать, кто отвечает за выполнение действий на каждом участке.

Алгоритм создания секции:

  1. Щелкнуть по кнопке Swimlane (Секция) на панели инструментов.

  2. Щелкнуть по диаграмме действий, чтобы создать на ней новую секцию.

  3. Дважды щелкнуть по названию новой секции, чтобы открыть диалоговое окно Specification (Параметры) и в поле Name ввести нужное название секции. Нажать кнопку ОК.

Для обозначения начального и конечного состояний в потоке управления системы используются специальные символы.

Последовательность создания начального и конечного состояний:

  1. Щелкнуть по кнопке Start State (Начальное состояние) или End State (Конечное состояние) на панели инструментов.

  2. Щелкнуть по диаграмме действия, чтобы поместить не нее символ конечного или начального состояния.

    1. Разработка диаграммы классов

Главная диаграмма классов в логическом представлении модели обычно отображает пакеты системы. Каждый пакет также имеет свою главную диаграмму классов, которая обычно содержит общедоступные классы пакета. Другие диаграммы создаются по необходимости.

Программа Rational Rose автоматически создает главную диаграмму классов в логическом представлении модели.

Чтобы добавить пакеты к главной диаграмме классов нужно дважды щелкнуть по пункту списка Main Diagram (Главная диаграмма) в браузере, чтобы открыть диаграмму, а затем, выбрав нужный пакет, перетащить его на диаграмму.

Для создания главной диаграммы класса пакета в программе Rational Rose необходимо дважды щелкнуть по изображению пакета на диаграмме классов. После того, как пакет откроется, появится главная диаграмма классов. Для добавления классов, необходимо выбрать нужный класс и перетащить его с помощью мыши на диаграмму. Для отображения стереотипа класса на диаграмме можно воспользоваться командой Format → Stereotype Display (Формат → Показать стереотип).

Для установки/сброса видимости класса нужно установить/сбросить флажок Show Visibility (Показать видимость) на вкладке Diagram контекстно-зависимого меню Options (для конкретного класса) или меню Tools → Options (для отображения всех классов).

Модель классов разрабатывается аналогично, но более подробно.

    1. Разработка модели поведения

Для создания диаграммы последовательности действий в программе Rational Rose необходимо добавить в список браузера новую диаграмму. Для этого нужно щелкнуть правой кнопкой мыши по папке Logical View (Логическое представление) и в появившемся контекстно-зависимом меню выбрать команду New → Sequence Diagram (Создать → Диаграмма последовательности действий).

Для создания объектов и сообщений на диаграмме последовательности действий, прежде всего, нужно ее открыть, затем выбрать на панели инструментов сообщение или объект и перетащить его на диаграмму.

Заключение

В результате курсового проектирования была разработана информационная система сети поликлиник "Семейный доктор". Основой для создания информационной системы послужили проблемы предметной области. В качестве среды разработки было выбрано CASE-средство фирмы Rational Software Corporation – Rational Rose 2000, предназначенное для автоматизации этапов анализа и проектирования предметной области.

После изучения универсального языка моделирования UML и принципов использования среды Rational Rose, была построена концептуальная и логическая модели информационной системы.

Использование данной ИС упрощает доступ к персональным данным пациента, централизует хранение всех данных о пациенте и уменьшает количество противоречивых данных. Благодаря этому представляется возможность сократить численности административно-управляющего персонала и расходов на зарплату, избежать снижение пропускной способности сети поликлиник при увеличении количества пациентов, повысить уровень качества обслуживания и лечения. Все это приводит к повышению управляемости компанией в целом и, как следствие, к увеличению прибыли.

Результаты проектирования могут являться основой для разработки конечного продукта информационной системы сети поликлиник.

Свежие статьи
Популярно сейчас
Почему делать на заказ в разы дороже, чем купить готовую учебную работу на СтудИзбе? Наши учебные работы продаются каждый год, тогда как большинство заказов выполняются с нуля. Найдите подходящий учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4125
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее