49537 (Выполнение расчетов, разработка баз данных и оформление технической документации с использованием табличных и текстовых процессоров), страница 2

2016-07-30СтудИзба

Описание файла

Документ из архива "Выполнение расчетов, разработка баз данных и оформление технической документации с использованием табличных и текстовых процессоров", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "49537"

Текст 2 страницы из документа "49537"

=СРЗНАЧ(М4;N4)

Где М4 – скорость по шоссе, N4 – на плаву.

Для определения, является ли длина БТР больше 6500 мм истинной или ложью, использовалась логическая функция. Использовалась относительная адресация.

Пример:

=ЕСЛИ(M4>6500;"да";"нет")

Где М4 – длина БТР.

Для определения общего количества человек на данном БТР проводился расчет по формуле с использованием математической функции. Использовалась относительная адресация.

Пример:

=В4+С4

Где В4 – экипаж, С4 – десант.

3.2 Автоматическое подведение итогов

Для создания структурирования с автоматическим подведением итого необходимо сначала в меню «Данные» выполнить команду «Итоги». Затем в появившемся диалоговом окне в раскрывающемся списке «При каждом изменении в» выбрать поле «Тип образца», в раскрывающемся списке «Операция» выбрать поле «Среднее» и в поле «Добавить итоги по» с помощью флажков указать « «Макс. скорость по шоссе». Результат автоматического подведения итогов приведен на рисунке 7.

Рисунок 7 – Итоги

4. Разработка сводных таблиц

Для создания сводных таблиц необходимо открыть мастера сводных таблиц в меню «Данные» и выполнить все инструкции мастера.

В сводной таблице 1 используются следующие поля: «Боевая масса»,»Экипаж», «Десант». Над данными полями произведена Операция «Среднее». Сводная таблица 1 приведена на рисунке 8.

Рисунок 8 – Сводная таблица 1

В сводной таблице 1 используются следующие поля: «Боевая масса»,»Экипаж», «Десант». Над данными полями произведена Операция «Среднее». Сводная таблица 1 приведена на рисунке 9.

Рисунок 9 – Сводная таблица 2

5. Создание диаграмм

Для создания диаграмм необходимо открыть мастера диаграмм в меню «Вставка» и выполнить все инструкции мастера.

Диаграмма 1 отображает зависимость запаса хода от марки БТР.

Тип: Объемная круговая диаграмма.

Диаграмма 1 представлена на рисунке 10.

Рисунок 10 – Диаграмма 1

Диаграмма 2 отображает зависимость мощности двигателя от марки БТР.

Тип: гистограмма.

Диаграмма 2 представлена на рисунке 11.

Рисунок 11 – Диаграмма 2

6. Разработка алгоритма

Если при работе с Microsoft Excel возникает необходимость несколько раз выполнить одну и ту же последовательность действий, то можно записать эту последовательность под определенным именем. Записанная под определенным именем последовательность действий и будет называться макросом.

Для создания макроса нужно разработать алгоритм

Алгоритм – точное предписание исполнителю совершить определенную последовательность действий для достижения поставленной цели за конечное число шагов

Во-первых, необходимо ввести данные, с которыми будут производиться таблиц. вычисления в ячейки, соответствующие заранее созданным заголовкам электронных

После ввода необходимой информации в таблицы, необходимо задать формулы и функции, по которым будут производиться вычисления над введенными данными.

Алгоритм представлен на рисунке 12.





Да Нет









Рисунок 12 - Алгоритм

7. Создание макроса

Для записи макроса сначала необходимо в меню «Сервис» подменю «Макрос» выбрать команду «Начать запись» и в открывшемся диалоговом окне определить имя макроса и сочетание клавиш, которое будет вызывать данный макрос. Затем следует выполнить необходимые расчеты. После этого нужно остановить запись, выбрать в меню «Сервис» подменю «Макрос» команду «Остановить запись».

Ниже приведен листинг созданного макроса:

Sub Макрос()

' Макрос2 Макрос

' Макрос записан 28.10.2007 (Андрей)

'

' Сочетание клавиш: Ctrl+p

'

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("B18").Select

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("B19").Select

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("B20").Select

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("B21").Select

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("B22").Select

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("B23").Select

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("B24").Select

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("B25").Select

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("B26").Select

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("B27").Select

ActiveCell.FormulaR1C1 = "=AVERAGE(R[-13]C[11],R[-13]C[12])"

Range("C17").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("C18").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("C19").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("C20").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("C21").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("C22").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("C23").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("C24").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("C25").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("C26").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("C27").Select

ActiveCell.FormulaR1C1 = "=IF(R[-13]C[2]>6500,""да"",""нет"")"

Range("D17").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D18").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D19").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D20").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D20").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D21").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D22").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D23").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D24").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D25").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D26").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

Range("D27").Select

ActiveCell.FormulaR1C1 = "=SUM(R[-13]C[-2],R[-13]C[-1])"

End Sub

Заключение

В ходе выполнения курсовой работы была разработана базы данных, проведены операции сортировки и фильтрации; разработаны электронная таблица, содержащая постоянные значения различных типов, расчеты по формулам и функциям различных типов с использованием абсолютной и относительной адресации ячеек, автоматическое подведение итогов и две сводные таблицы. Графически были изображены полученные в таблице зависимости при помощи диаграмм различных типов. Также был разработан алгоритм и создан макрос для выполнения расчетов по формулам. С помощью созданного шаблона был оформлен отчет.

Таким образом, было полностью выполнено задание по курсовому проекту.

Список используемых источников

1. Карпов Б. Microsoft Office 2000: справочник. – СПБ.: Питер, 2001.- 448 с.: ил.

2. Шунков В. Н. – Мн.: ООО «Попурри», 2000 – 448 с.:ил+вкл. 8с.

Свежие статьи
Популярно сейчас
А знаете ли Вы, что из года в год задания практически не меняются? Математика, преподаваемая в учебных заведениях, никак не менялась минимум 30 лет. Найдите нужный учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4125
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее