49028 (Создание базы данных о студентах ВУЗа), страница 2

2016-07-30СтудИзба

Описание файла

Документ из архива "Создание базы данных о студентах ВУЗа", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "49028"

Текст 2 страницы из документа "49028"

При выборе меню «Файл -> Сохранить как (Ctrl+S)» в любом случае передается параметр «1».

2.3.5 Закрытие программы

Управление получит Form_QueryUnload(Cancel As Integer, UnloadMode As Integer) (Приложение 1. с.39). События, описанные в этой процедуре, выполняются при попытке закрыть форму. Если параметр Cancel этой процедуры будет равен 1, то происходит отмена выхода и форма не закрывается. Это лежит в основе процесса выхода из программы. В случае отрицательного ответа на предложенное сообщение выход осуществлен не будет. Завершение работы программы происходит только при подтверждении выхода.

2.3.6 Добавление данных

Если запись выделена, то управление получит Процедура Edit("Add", 0) (Приложение 1. с.35). Эти параметры обозначают, что необходимо добавить запись. Второй параметр для добавления записи не имеет значения. Он нужен при редактировании. Затем будет показана форма добавления записи frmAdd (Приложение 2. с.62), в которой необходимо заполнить правильно все поля. Ввод контролируется модулем modInspect (Приложение 1. с.60) и функцией Date_raz(date1 As String, date2 As String) As Long из модуля modData (Приложение 1. с.59), которая возвращает число, равное разности сумм произведений +*30+ двух дат, передаваемых в качестве параметров При нажатии кнопки «Добавить». В случае правильного ввода, запись появится в listbox-элементах главной формы.

2.3.7 Удаление данных

Если запись выделена, управление получит Процедура Edit("Del", lstZapis(0).ListIndex). Эти параметры обозначают, что необходимо удалить запись с номером выделенной записи. После подтверждения удаления запись будет удалена из всех полей таблицы.

2.3.8 Изменение данных

Если запись выделена, управление получит Процедура Edit("Edt", lstZapis(0).ListIndex). Эти параметры обозначают, что необходимо редактировать запись с номером выделенной записи. Затем будет показана форма редактирования записи frmEdit (Приложение 2. с.63) (она очень похожа на форму добавления записи, но в ней уже заполнены все поля), в которой вы можете изменить значение одного или нескольких полей данной записи (Ввод контролируется теми же модулями, что и при добавлении). Нажмите кнопку «Изменить». В случае правильного ввода, запись изменится в listbox-элементах главной формы.

2.3.9 Формат данных

Изменение формата текста производится в меню «Формат». Выбрав нужный подпункт, вы можете изменить шрифт и цвет текста. Шрифт изменяется в пределах тех значений, которые допускает операционная система, так как производится с помощью вызова стандартного диалога загрузки шрифта (вызов производит CommonDialog). Вся введенная информация изменит свой шрифт на выбранный. Для изменения цвета символов CommonDialog вызывает окно с палитрой, где можно выбрать цвет заливки символов, а затем нажать кнопку «ОК» или «Отмена» (в этом случае цвет будет выбран стандартный, то есть, черный).

2.3.10 Поиск данных

Public Sub Search(strType As String) (Приложение 1. с.35) – это процедура поиска. Если strType=fst, то производится поиск по первой букве в выбранном поле, а результат помещается в таблицу формы результатов frmSearch (Приложение 2. с.64), после чего процедура выводит эту форму на экран. При загрузке формы поиска в строку состояния записывается количество записей в таблице.

Кроме того, возможен поиск по запросам. Для каждого запроса отведена своя процедура, выполняющая свою конкретную задачу. На той же форме результатов будет показан результат поиска по выбранному запросу, а внизу, на StatusBar – количество найденных записей. При двойном щелчке на записи в поле поиска, она выделяется в основной форме, а форма поиска выгружается.

2.3.11 Построение диаграмм

Сначала загружается форма диаграмм frmDiagramms (Приложение 2. с.63), на которой с помощью кнопки выбирается тип диаграммы, а затем с помощью ComboBox или ListBox параметры, по которым необходимо построить диаграмму. Диаграммы строятся внути PictureBox-элементов, для каждого вида диаграмм отдельных. Для каждого вида диаграмм вызывается своя процедура: Graf() (Приложение 1. с.54) – для графика, Round(ob_kol As Long, kol1 As Long) (Приложение 1. с.53) – для круговых. Параметр ob_kol обозначает общее количество записей (100%), а kol1 – текущее количество, для построения сектора; Stolb(Групп As Integer) – для столбчатых, где Групп – это количество групп, которое нужно для определения ширины столбцов.

2.3.12 Сортировка

Для сортировки данных по определенному столбцу используется стандартное сравнение Visual Basic и функции больше (>) и меньше (<). Для сортировки по датам используется функция Date_raz(date1 As String, date2 As String) As Long из модуля modData, которая описана выше.

2.3.13 Справка и информация о программе

«Справка – О программе». Перейдя по этому меню, вы попадаете на форму frmAbout (Приложение 2. с.65), где написано о программе, версии, разработчике и авторских правах. Это стандартный About Dialog Visual Basic. Также с помощью стандартных средств Visual Basic реализована кнопка «О системе» на этой форме, собирающая информацию о вашем компьютере. Справка представляет собой «сайт» (HTML-страницы, соединенные ссылками и файлы с изображениями), который отображается в компоненте Web-browser на форме.


3. ТЕХНОЛОГИЧЕСКАЯ ЧАСТЬ

3.1 Руководство системного программиста

3.1.1 Составные части программного продукта

  • Файл проекта MyDataBase.vbp

  • Файлы модулей : modAbout.bas, modData.bas, modInspect.bas

  • Файлы форм: frmAbout.frm (О программе), frmAdd.frm (Добавление записи), frmDatabase.frm (Окно с таблицей), frmDiagramms.frm (Форма диаграмм), frmEdit.frm(Редактирование записи), frmHelp.frm (Справочная система), frmSearch.frm (Форма результатов поиска), frmStart.frm (Стартовая заставка).

  • Файлы справки: Sort.html, Save.html, Open.html, New.html, Exit.html, Edt.html, Add.html, Del.html, Diags.html, Search.html, Main.html, About.html, Errors.html

  • Всего при создании проекта было разработано 8 форм, 3 модуля, 13 файлов справки и 1 база данных. При разработке использовалась среда Visual Basic 6.0.

3.1.2 Запуск и выполнение

Готовая программа представляет собой файл MyDataBase.exe, который и необходимо запустить. Если в системе установлены все требуемые файлы и библиотеки, то появится окно заставки, и программа начнет свою работу.

3.1.3 Системные требования

  • Процессор 200 МГц

  • Операционная система Windows 95/NT/98/ME/2000/XP

  • Оперативная память не ниже 32Мб

  • Видеокарта SVGA

  • Клавиатура, мышь

  • 3 MB места на жестком диске (если все необходимые компоненты были установлены ранее, достаточно 2 MB)

3.1.4 Комплект ПО

В комплект программного обеспечения входит исполняемый файл MyDataBase.exe и выше указанные файлы справки и картинки: Menu_File.JPG, Menu_Search.JPG, Menu_Edit.JPG, Menu_Format.JPG, Menu_Sort.JPG, Open_Dialog.JPG, Msg_Open.JPG, Msg_New.JPG, Msg_Exit.JPG, frmEdit.JPG, frmAdd.JPG, Msg_Del.JPG, frmDiags.JPG, frmSearch.JPG, frmDatabase.JPG, Menu_Help.JPG, frmAbout.JPG, ErrSearch.JPG, NumError.JPG, Drob.JPG, Min.JPG, Max.JPG, DateError.JPG.

3.1.5 Тестирование программы

  • Запустите файл MyDataBase.exe

  • Выберите пункт «Открыть» в меню Файл или кнопку «Открыть» на панели инструментов. В появившемся диалоговом окне выберите имя открываемого файла. Таблица базы данных будет загружена из выбранного файла. Также вы можете сформировать свою базу данных путем добавления записей.

  • Выберите пункт «Добавить запись» в меню «Редактировать». Появится окно Добавления записи. Заполните поля записи, например:

СтудентМасляев Евгений

ГруппаИТД-31

Название курсаИнформатика

Название работы Курсовая работа

Дата выдачи09.09.2006

Оценка5

Дата сдачи20.11.2006

  • Нажмите кнопку «Добавить». В основном окне базы данных окне появится запись.

  • Выберите пункт «Файл->Сохранить как» в меню или нажмите кнопку «Сохранить» на панели инструментов. В появившемся окне выберите имя нового файла. База данных сохранится в новом файле. Имя текущего файла, с которым в данный момент происходит работа, написано в заголовке окна.

  • Выберите пункт «Создать» в меню для создания новой базы и очистки полей

  • Снова откройте созданный вами файл по выше описанному алгоритму.

Если после выше перечисленных действий в открывшейся базе данных

будет находиться выше представленная запись, то создание, сохранение и открытие базы данных надо полагать успешным.

3.2 Руководство оператора

3.2.1 Назначение программы

Проект является программным обеспечением для создания баз данных о работах студентов университета. Программа выводит информацию в табличной форме, позволяет добавлять, изменять, удалять, сортировать данные о студентах, записанные в базе данных, а так же выводить данные по запрашиваемому условию, производить поиск по первой букве и строить диаграммы отношений.

3.2.2 Краткое описание алгоритма работы с программой

Исполняемый файл – Database.exe

Для открытия файла выберите пункт меню Файл –> Открыть.

Для создания резервной копии – пункт меню Файл –> Сохранить как

Для добавления записи – меню Редактировать –> Добавить

Для удаления записи ее необходимо выделить и выбрать меню Редактировать–> Удалить или нажать кнопку Delete на клавиатуре. Удаление нужно подтвердить нажатием кнопки «Да» в окне сообщения.

Для выполнения запросов предназначено меню «Запросы». Выберите «Поиск–> По запросу –> », и программа осуществит поиск по выбранному условию и выведет результаты на форму поиска.

Сортировка выполняется при выборе сортировка в меню базы данных. Выберите поле для сортировки, а затем вид сортировки в пункте «Сортировка» или на панели инструментов.

Для поиска данных по первой букве выберите меню «Поиск –> По первой букве». Введите букву в появившееся окно и нажмите «Ok». Найденная информация будет отображена на форме поиска.

Для получения справки и информации о программе выберите меню «Справка».

Многие пункты меню дублируются на панели инструментов. Далее каждое действие будут описано более подробно.

3.2.3 Создание базы данных

Если вам требуется создать новую базу данных, нет необходимости удалять записи одну за одной, а можно просто нажать на кнопку "Создать базу" на панели инструментов, перейти по меню "Файл -> Создать" (Рис.1)

Рис.1

И или нажать горячую комбинацию клавиш Ctrl+N. Если файл был сохранен до этого, то программа просто очистит таблицу, и ваши данные останутся в неизменном виде. Если же файл сохранен не был, то данные в предыдущей таблице вернутся в состояние предыдущего сохранения файла или будут удалены, если этот файл не существует. В любом случае, вы получите сообщение о том, что необходимо подтвердить действие (Рис.2), и, в случае отрицательного ответа, операция будет отменена.

Рис.2


3.2.4 Открытие базы данных

Открыть уже сохраненный файл можно, используя кнопку на панели задач или меню "Файл -> Открыть". (Рис.3)

Рис.3

Ответьте положительно на следующее сообщение (Рис.4), если файл уже сохранен.

Рис.4

При нажатии на кнопку на экране появится диалоговое окно для

выбора файла.

Рис.5

Выберите нужный файл, нажмите кнопку "Открыть", и его содержимое появится в таблице на главной форме.

3.2.5 Сохранение базы данных

Сохранить данные в MyDataBase можно путем нажатия на кнопку с изображением дискеты на панели инструментов или перейдя в меню "Файл -> Сохранить" или "Файл -> Сохранить как". (Рис.6)

Рис.6

При нажатии кнопки на панели инструментов, программа выполняет пункт "Сохранить как", то есть, сохранить в новый файл, если база сохраняется в первый раз. При этом требуется в появившемся диалоге ввести имя и выбрать путь к новому файлу. Если текущая база уже была сохранена ранее, то нажатие на кнопку сохранения приведет к изменению текущего файла в соответствии с таблицей записей. Пункт меню "Файл -> Сохранить как" сохраняет базу в новый файл в любом случае. Сохранение файла - очень важный момент. Сохраняйте файлы чаще, чтобы не потерять важные данные, ведь в представленной программе есть все необходимые средства для того, чтобы сделать этот процесс как можно более быстрым и удобным.

3.2.6 Удаление записи

Выделите запись, щелкнув на ней левой кнопкой мыши, и нажмите клавишу delete. Ответив "Да" на сообщение о подтверждении (Рис.7), вы удалите выбранную запись из базы.

Свежие статьи
Популярно сейчас
Зачем заказывать выполнение своего задания, если оно уже было выполнено много много раз? Его можно просто купить или даже скачать бесплатно на СтудИзбе. Найдите нужный учебный материал у нас!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4121
Авторов
на СтудИзбе
667
Средний доход
с одного платного файла
Обучение Подробнее