48597 (Разработка оболочки экспертной системы), страница 4

2016-07-30СтудИзба

Описание файла

Документ из архива "Разработка оболочки экспертной системы", который расположен в категории "". Всё это находится в предмете "информатика" из 1 семестр, которые можно найти в файловом архиве . Не смотря на прямую связь этого архива с , его также можно найти и в других разделах. Архив можно найти в разделе "курсовые/домашние работы", в предмете "информатика, программирование" в общих файлах.

Онлайн просмотр документа "48597"

Текст 4 страницы из документа "48597"

Рисунок 3.3 – Окно для ввода и редактирования правил

Чтобы добавить новое правило необходимо нажать кнопку «Добавить правило» или выбрать команду меню «Правка - Добавить правило». Для удаления правила можно нажать кнопку «Удалить правило» или выбрать команду меню «Правка - Удалить правило».

Для добавления переменных условия в правило необходимо нажать кнопку «Добавить условие» или выбрать команду меню «Правка - Добавить условие». Для удаления переменной условия можно нажать кнопку «Удалить условие» или выбрать команду меню «Правка - Удалить условие».

Если какие-то переменные условия не сохранены, эксперту сразу будет предложено ввести вопрос для данной переменной условия (рисунок 3.4).

Рисунок 3.4 – Окно для ввода вопроса к переменной условия

Если переменной вывода нет в ТПВ, то эксперту будет предложено ввести рекомендацию для определенного значения переменной вывода (рисунок 3.5).

Рисунок 3.5 – Окно для ввода рекомендации к переменной вывода

Окно данной программы представлено из нескольких вкладок: «Правила», «ТПУ», «ТПВ», «Списки» (рисунок 3.1).

Первая вкладка предназначена непосредственно для ввода и редактирования правил.

Вкладка «ТПУ» предназначена для просмотра таблицы переменных условия (рисунок 3.6). Если к какой-то переменной условия еще не было введено вопроса, то в таблице переменных условия эта переменная не отмечается «галочкой». Чтобы ввести вопрос, необходимо ввести его в поле «Вопрос к ПУ».

Рисунок 3.6 – Вкладка «ТПУ»

Вкладка «ТПВ» предназначена для просмотра таблицы переменных вывода (рисунок 3.7). Если к какой-то переменной вывода еще не введена рекомендация, то необходимо ввести ее в поле «Рекомендация».

Рисунок 3.7 – Вкладка «ТПВ»

Вкладка «Списки» предназначена для просмотра списков переменных условия и вывода (рисунок 3.8).

Рисунок 3.8 – Вкладка «Списки»

Если эксперт создаст правило, которое уже было, то будет выведено соответствующее сообщение об ошибке. Также сообщения об ошибке выводятся при недозаполнении правил.

Чтобы сохранить базу необходимо выбрать команду меню «Файл - сохранить» или «Сохранить как…». Для создания ново базы необходимо выбрать команду меню «Файл - Новая база».

В меню также имеется вкладка «Справка», где можно посмотреть информацию об авторе (рисунок 3.9) и руководство эксперта (рисунок 3.10).

Рисунок 3.9 – Информация об авторе

Рисунок 3.10 – Руководство эксперта

3.4.2 Руководство пользователя

Для запуска программы необходимо открыть исполняемый файл «Klient.exe». При этом появится окно, приведенное на рисунке 3.11. Для начала работы экспертной системы в режиме консультации необходимо загрузить необходимую вам базу знаний. Для этого нужно выбрать команду меню «Файл - Загрузить базу».

Рисунок 3.11 – Окно программы «Клиент»

Для начала работы необходимо нажать кнопку «Начать работу» (рисунок 3.12).

Рисунок 3.12 – Начало работы экспертной системы

Пользователю будет представлен вопрос и несколько вариантов ответа на него. Необходимо выбрать нужный вариант ответа на вопрос и нажать кнопку «Принять» либо выбрать команду меню «Действия - Следующий вопрос». Если необходимо начать опрос заново, необходимо нажать кнопку «Начать работу» либо выбрать команду меню «Действия - Начать заново».

После ответа на все представленные вопросы, экспертная система выдает конечный результат в виде рекомендации (рисунок 3.13).

Рисунок 3.13 – Рекомендация экспертной системы

Если пользователю необходимы разъяснения данного результата, необходимо нажать кнопку «Почему». При этом появятся все сработанные рекомендации и выводы (рисунок 3.14).

Рисунок 3.14 – Пояснение рекомендаций

Заключение

Разработанная в ходе выполнения курсового проекта оболочка для экспертной системы является актуальной на сегодняшний день, так как предоставляет большие возможности в различных предметных областях. Созданная в данной оболочке экспертная система может помочь при принятии решений в сложных ситуа­циях, например при диагностике заболеваний, проектировании микросхем, управлении сложными объектами (энергосистемами, атомными электростанциями и т. п.), идентификации неисправностей в электронных схемах, при решении задач оптимального размещения финансовых средств и т.д.

В ходе данного работы были разработаны два независимых модуля (модуль «Эксперт» и модуль «Клиент»), которые используют одну базу знаний. В интерфейсе программы для эксперта были предусмотрены следующие возможности:

- добавление новых правил;

- удаление правил;

- редактирование существующих правил;

- сохранение базы знаний;

- открытие ранее сохраненных баз знаний;

- просмотр руководства по использованию данной экспертной системы.

В интерфейсе программы для пользователя были предусмотрены следующие возможности:

- открытие существующей базы знаний;

- выбор одного из предложенных ответов на вопрос;

- вывод рекомендаций;

- вывод пояснений к рекомендациям.

Таким образом, разработанная оболочка экспертной системы выполняет все задачи, поставленные в начале работы.

Список используемой литературы

  1. А.Я. Архангельский. Программирование в Delphi 7.

  2. Гаврилова Т.А., Хорошевский В.Ф. Базы знаний интеллектуальных систем – СПб.: Питер, 2001. – 384 с.: ил.

  3. Попов Э.В. Экспертные системы: Решение неформализованных задач в диалоге с ЭВМ. – М.: Наука. Гл. ред. физ.-мат. лит., 1987. – 288 с. – (Пробл. искусственного интеллекта).

  4. Элти Дж., Кумбс М. Экспертные системы: концепции и примеры / Пер. с англ. и предисл. Б.И.Шитикова. – М.: Финансы и статистика, 1987. – 191 с.: ил.

  5. Хейес-Рот Ф., Уотерман Д., Ленат Д. Построение экспертных систем. Пер. с англ. – М.: Мир, 1987.-447с.

  6. Зартенова Л.Г. Методические указания по курсу «Экспертные системы и искусственный интеллект» – КарГТУ, кафедра САПР.

Свежие статьи
Популярно сейчас
Как Вы думаете, сколько людей до Вас делали точно такое же задание? 99% студентов выполняют точно такие же задания, как и их предшественники год назад. Найдите нужный учебный материал на СтудИзбе!
Ответы на популярные вопросы
Да! Наши авторы собирают и выкладывают те работы, которые сдаются в Вашем учебном заведении ежегодно и уже проверены преподавателями.
Да! У нас любой человек может выложить любую учебную работу и зарабатывать на её продажах! Но каждый учебный материал публикуется только после тщательной проверки администрацией.
Вернём деньги! А если быть более точными, то автору даётся немного времени на исправление, а если не исправит или выйдет время, то вернём деньги в полном объёме!
Нет! Мы не выполняем работы на заказ, однако Вы можете попросить что-то выложить в наших социальных сетях.
Добавляйте материалы
и зарабатывайте!
Продажи идут автоматически
4098
Авторов
на СтудИзбе
673
Средний доход
с одного платного файла
Обучение Подробнее